Loading latest G'MIC in GIMP 2.9.6?


#1

I’ve tried various ways to install the latest G’MIC (2.0.3 QT and then 2.0.4_pre QT) into GIMP 2.9.6 on Windows 7 64-bit. When I launch GIMP it’s simply not available. No error messages. Is this even feasible?


#2

Has it worked before? What have you tried so far? I haven’t tried for this combination yet.


#3

The only bleeding-edge combination that has worked for me was GIMP 2.9.5 from Partha along with G’MIC 2.0 dev version. I’m sticking with QT versions of G’MIC because all the GTKs have been buggy on my PC. Although I’ve never been sure whether Partha is officially inside the loop, his GIMP builds have worked well for me.


#4

I use @partha’s portable builds. Upgrading G’MIC-GTK used to work but not G’MIC-QT. I believe that @David_Tschumperle said somewhere that he would package G’MIC-QT better in the near future to make it easier to install.


#5

Does that mean I need to try the GTK version?


#6

No, it is not supported anymore. Actually, some things that used to work don’t anymore. @partha will probably update his builds in a few weeks. Be patient :sunny:.


#7

Pa - what? OK will do.


#8

gmic-gimp-qt does throw up an error in Windows Gimp 2.9.6 Seems a problem with libcairo-2.dll There is a temporary fix if you read through:

http://gimpchat.com/viewtopic.php?f=28&t=15844#p219359

For installation, the .exe installer will try and add it to .gimp-28 Edit that to ‘another location’.
Add the path to ‘another location’ in Edit -> Preferences -> folders

Edit: Normally I use linux, compile my own gmic_gimp_qt for Gimp 2.9 so no problems.

Trying that fix in a Win 10 VM and still get a whole list of errors from gmic-gimp-qt. Looks like Win users need a gmic-gimp-qt update.


#9

@afre

Indeed. :smile:

I have updated my builds, Windows and Mac. Included also is pre 2.0.4 G’MIC.

Thanks,
Partha


#10

Yes, indeed. :sunny:.

I have just updated both Windows and Mac builds. Included also is the
pre 2.0.4 G’MIC. Enjoy.