Lua Script Manager missing?

I’ve built from source and installed from the ppa provided from the OBS and I don’t have the option to install the Lua Script Manager in the release version of 3.2.1. I had it running fine in my previous installation of 3.0.1 and I haven’t changed anything. When I run darktable -d lua I get:

dave@dave-desktop:~/darktable$ darktable -d lua
1.027476 LUA LUA_DIR is /home/dave/.config/darktable/lua
1.027500 LUA ERROR : .../.config/darktable/lua/script-manager/script_manager.lua:645: Module script-manager/script_manager is not compatible with API 6.0.0

I don’t know what I’m missing. I’m still new to building from source so I had hoped the package from the ppa would have sorted me out.

What does your luarc file contain?

Have fun!
Claes in Lund, Sweden

require "script-manager/script_manager"
require "wpferguson/<name of script>"

I’m not sure if it’s still required with Script Manager being built in? I installed it using his instructions here: https://github.com/wpferguson/script-manager

Let’s ask the author, @wpferguson ping.

1 Like

Is that all?
My luarc is 24.0 k large.

That’s all that was needed to have it run on 3.0.1.

I just removed all lua related files and folders from ~/.config/darktable and reinstalled following instructions from @wpferguson git hub. I recreated my luarc and copy/pasted the contents of script_manager.lua to it. When I run darktable -d lua I still get:

dave@dave-desktop:~/.config/darktable$ darktable -d lua
0.968297 LUA LUA_DIR is /home/dave/.config/darktable/lua
0.968321 LUA ERROR : /home/dave/.config/darktable/luarc:645: Module <unnamed module> is not compatible with API 6.0.0

And I’m still confused why it wasn’t part of my regular install of 3.2.1?

And how big is your luarc file now?

29 KB

It ought to be 24.0 KiB if you followed the instructions on GitHub?

I’m not great at this stuff but it was easy enough and worked fine on my previous version.

In your luarc file just enter the line
require "tools/script_manager"

I’ll go look at the instructions and see if I need to update them

1 Like

@David_LaCivita, looking at the error message
I’m guessing that you might have pasted it twice. The API check is usually occurs within the first 10 lines of code, not at line 645. :slightly_smiling_face:

OK, I’ve got it now.
I copied script_manager.lua to my lua directory though the instructions say:

“copy script_manager.lua to $HOME/.config/darktable/luarc”. It sounded like I needed my luarc to contain the contents of script_manager.lua.

Still, back at the beginning, without changing anything I still got an error after updating to 3.2.1. If it’s just me then we can carry on. Hopefully no one else has a problem.
I can’t say it enough, this forum is the best. Thanks everyone!

@David_LaCivita, one final thought. If all else fails…

cd ~/.config/darktable
mv lua lua.old
mv  luarc luarc.old
git clone https://github.com/darktable-org/lua-scripts.git lua
echo "require \"tools/script_manager\"" > luarc

And if you want my extra scripts, then

cd ~/.config/darktable/lua
git clone https://github.com/wpferguson/extra-dt-lua-scripts.git wpferguson

script_manager will detect them the next time you run darktable and you can manage them from there.

Luckily, I know enough to understand all of that just not enough to do it like that. Ultimately, that’s exactly what I did but with the GUI.
Your instructions don’t mention what to add to the luarc and that was the detail I was missing.

I’ll look at the instructions and update them. When I first wrote them I had one mind set, but I’ve come around to the require statement in the luarc as the easiest and most reliable across all operating systems.

1 Like

Ich have got the same problem, but i did not solve it with the tipps given here. Even the “last thougth” did not help.

In my version of the script_manager-lua the API check occures in line 645, not in line 10
Line 354:

-- api check

dt.configuration.check_version(…,{5,0,0})

It seems to check version 5.0.0. instead of 6.0.0., as shown in the error messor above.

Now, I have installed it totally new from the Github and now it seems to work fine without the error message. The found LUA Script are loaded. But where can I find der “Script Manager” ? I do not see the Modul at the Lighttable.

(Linux, DT 3.2.1)