Manjaro: xrandr --dpi 160 - where?


#1

Evening, all,

At last I have managed to get my Manjaro to understand that I would like to boot into dimension 3840x2160, but it always boots into resolution 96x96 dots per inch.
I am after 160 dpi, but I do not understand how to activate the command [xrandr --dpi 160] automatically… :cry:

Suggestions are very welcome!

Sincerely,
Claes in Lund, Sweden


(Mica) #2

What desktop environment are you using? Can’t you set it there?


#3

Xfce – and I can set it “per session”. But as soon as I re-boot,
it’ll revert to 96x96.


(Mica) #4

Ah. I’d put the command into a shell script, then execute the script on login.


(Martin Scharnke) #5

Happy for you Claes, that you are making progress! :slight_smile: I have never understood the Xfce ways of doing things very well … I hope that the suggestion @Mica made re shell script can work for you.


(Morgan Hardwood) #6

@Claes have you tried adding xrandr --dpi 160 to /etc/profile?


#7

Evening, Old Thing,

Level 3 Pleb, eh? How much more do you need to become a 1st Class Centurion?

No, unfortunately the /etc/profile advice did not work either, nor did my standard invoke-at-start tricks. I presume that Manjaro/xfce is somewhat special.

Presently, I am playing with Manjaro/KDE which looks much more HiDPI-friendly…

[I also tried Fedora 29, but it kindly refuses to boot a Ryzen 7/Crosshair VII Hero combination.]

Ah well…

Have fun!
Claes in Lund, Sweden


(Glenn Butcher) #8

Does Manjaro have /etc/rc.local, or equivalent? /etc/profile will only be executed for shells.


#9

No, have not found any; neither in Manjaro/xfce nor in Manjaro/KDE.


(Mica) #10

In KDE, You can go to Settings > Display and Monitor > Displays, then click the Scale Display button near the bottom. That should let you scale your display.


#11

Agree! KDE seems much more HiDPI friendly!
See KDE paragraphs here: https://forum.manjaro.org/t/hidpi-support-in-manjaro/26088