Matte layers appearing as primary layers

color-layers

(Tom) #1

Hi,

I have been trying to transcode existing OpenEXRs ‘ZIP’ files to OpenEXR ‘ZIPS’ to get better playback.

Everything works fine in the render, however, the 4x matte layers that are in the original ‘ZIP’ files are being encoded as the primary layers in the new ‘ZIPS’ files, with the primary color layers moved to where the matte layers were in the original files.

Original OpenEXR ‘ZIP’ Channel List From ‘File Info…’:

  1. R
  2. G
  3. B
  4. A - alpha channel
  5. dimatte.red
  6. dimatte.blue
  7. dimatte.green
  8. dimatte.alpha

exr_zip_read

New OpenEXR ‘ZIPS’ Channel List From ‘File Info…’:

  1. R
  2. G
  3. B
  4. A - alpha channel
  5. Color.R
  6. Color.G
  7. Color.B
  8. Color.A

exr_zips_read

When reading the new OpenEXR (ZIPS) files, the default primary layers read are ‘Color.RGBA’ but these are the matte layers. When changing the layers to ‘Part1.Color.RGBA’ the primary channels appear.

My Write settings are in the below screenshot:
write_settings

Is there a way to stop the layers from swapping around during the rendering process?

Thanks,

Tom


(Frédéric Devernay) #2

for transcoding purposes, you should prefer using a python sript. Probably much faster and guaranteed to be lossless:
https://excamera.com/articles/26/doc/intro.html#exr-to-exr