Migrating darktable to Ubuntu from macOS

I would like to migrate my darktable work from my iMac to a new Linux computer running PopOS! (basically ubuntu). Would someone be so kind as to explain what needs to be done? I assume that moving my photo folder containing photos & .xmp files would be a simple move to the Pictures folder on the new computer. However, what do I need to do about the .config folder containing the library.db & data.db files? I would like to avoid having to re-import all of my photos and regenerating by configuration/preferences. Thanks in advance.

Your files will be in a new location so this will have to be updated anyway. DT doesn’t import files it really just indexes them so you won’t be able to avoid that… Most relevant info for your edits will be in your xmp files… your data.db will contain your presets etc so basically if you transfer your config files and import your photo’s again you should be good. I have not tried it from Mac to Linux but will there be any issue with reading those files on a different OS, ie the database files and config files?? It might be worth exporting your shortcuts presets and style just to be sure and then you can always reimport those into fresh configuration files…

1 Like

You can copy the config files from the Mac to the Linux box verbatim.

Assuming you want to copy the top most folder of your photo collection and not restructure anything, you can follow these instructions: darktable 4.0 user manual - collections

1 Like

I’ve contemplated making this jump myself from Mac to PopOS! I’d be interested to hear how you get on.

(I’ve used the method that @paperdigits links to when moving photos from my Mac onto an external drive. It works well. If your config files all work on Linux, and you just need to redirect darktable to the new directory/ies with the photos, then that would be excellent.)

First, I had my wife post the original question as I didn’t have an account. Second, thank you everyone for your quick replies. I have a Linux Mint setup which I was using to get more familiar with Linux before the new computer arrived. I have been trying to migrate some folders from my photo library on my iMac to the Mint computer and have run into some major issues. The biggest, and most unexpected, problem is that darktable doesn’t seem to recognize the .xmp files that I migrated from the iMac. Just selecting the new location of the folder as suggested by @paperdigits did not work so I tried importing which did import the photos but no edits were available. Any idea why the .xmp files are not being used?

Do you have the same versions of darktable in both systems? The xmp are darktable xmp in the Mac (not lightroom)?

Yes, both are darktable 4.0.1.

What about the second part of the question? Can you attach an xmp from the Mac machine(no picture needed)?

_75A5791.CR2.xmp (5.3 KB)

I think I know what is happening: when I import a folder w/ existing sidecar files dt is overwriting them with new “blank” files. If I set storage > write sidecar file for each image to “never” it seems to work. I guess what I need to do is figure out why the “search filmroll” method is not working, that should preserve the existing sidecar file.

What’s the error message or what happens?

You need to set the preference to look for updated sidecar files.

I was able to get this to work, sort of. I’m still losing my edits and getting white balance & color calibration errors. Honestly, I’m so confused at this point that I’m not sure where to go. Clearly this is not a smooth process, probably something to do with the Mac side of things. Wonder if I can still cancel my computer order? Thanks for your help.

Can you step us through what you did and the results?

I wish I could, LOL. I need to take a break then clear everything back to baseline and start again. I will start with a fresh copy of a folder with photos & sidecar files and copy the data.db & library.db files over from the Mac. I will then try to go through the process of trying to select the new folder location and report back exactly what happens.

Starting fresh, new copy of photos, sidecars, data.db and library.db.

  1. Launch dt and see folder structure from Mac with film rolls crossed out.
  2. Right click on one film roll and navigate to new location on Linux computer, select open and get a screen of skulls in lighttable
  3. Double click one of the skulls to open darktable and images appear but with no edits and errors shown in the Color Calibration & White Balance modules
  4. If I set storage > write sidecar file for each image to “never” and go thru sequence with another film roll I do get my edits back but the two errors are also present

If you enable the option to check for updated xmp files, do you still get the sidecar overwritten?

That was already done per your suggestion earlier.

I would suggest not copying the library.db. Just import the tree with recursive.

1 Like

Thank you for the suggestion but I don’t understand exactly what you mean by “tree with recursive.” Do you mean import into library fresh rather than use the relocate feature?

OK, I’ve been messing around with this for a while and I believe I have found the best method but I still have some baffling issues. First thing is to delete darktable from my Linux Mint computer including the darktable .config folder. Copy over a clean set of photos with sidecar files from my iMac. Install darktable and launch, in preferences set storage > write sidecar file for each image to “never” to prevent the .xmp files from being overwritten, then quit application. I then add my data.db file to the .config folder but not my library.db. Launch darktable and import each film roll which seems to retain my edits from the .xmp files. The problem that I still have is that on most, but not all, of the film rolls I have a White Balance error (“white balance applied twice”) where the setting has been changed to “user modified.” Changing this back to “camera reference point” fixes the issue. The problem is that I have to fix this on every photo in the film roll. I have no idea why this setting is being changed, it is fine in my iMac.

When all film rolls have been imported, change set storage > write sidecar file for each image to “on import” again.

Does anyone have any ideas why the white balance error is happening?