missing lcp in Rawtherapee 5.8

Having in stalled Rawtherapee on Mac the LCP drop downs are empty; it cannot auto select or manually select a lens profile. Do I need to install lensfun separate form the 5.8 dmg?

thanks in advance

LCP and lensfun correction are two different things.

for explanation see http://rawpedia.rawtherapee.com/Lens/Geometry#Profiled_Lens_Correction

I don’t know mac builds, but I think that lensfun database is bundled in the build.
So to use lensfun correction you have to use either automatic or manual.

It can happen that name decoded by RT is not compatible with lens name in lensfun DB the automatic will not work. in that case choose manual and search your lens in the drop down menus.

If your lens is not present come back here with all details.

thanks, have had a dig around. Lensfun DB / xml’s are stored here on my Mac (Mojave):

/applications/rawtherapee.app/contents/resources/share/lensfun

but when I click on the drop downs they are not populated they aren’t even “clickable” - I have ‘vi’ edited an xml to view the content of (LCP?) and the lens is there - so it seems to be an access problem - have added full access to RT to access the dir, but to no success - the drop down just aren’t being populated

I have the same problem on Catalina

As building for MAC seems challenging, perhaps the Lensfun DB could not be located in the right place. To correct that:

  • Find where is located your config directory: see http://rawpedia.rawtherapee.com/File_Paths
  • edit the options file
  • at the end of options file, you will find a lensfun section
    [Lensfun]
    DBDirectory=share/lensfun
  • correct the path. I think it can be relative or absolute (edit relative to the rawtherapee.exe location)
  • restart RT

Report here the result.
Please provide where you downloaded the build and the build name.

thanks - had look, that directory / file path does not exist on my Mac - so there must be something wrong with the package that I downloaded - which was from https://rawtherapee.com - on the home page - Mac OS 64

all the best

  • if the lensfun section is not present, I should add the section at the end of your option file:

    [Lensfun]
    DBDirectory=/applications/rawtherapee.app/contents/resources/share/lensfun

  • perhaps there are somewhere Rawtherapee nightly builds for mac, but I have no idea where they are. This build error is perhaps already corrected.
    ping @Carmelo_DrRaw and @HIRAM

@HIRAM has them in his keybase, I’m mobile now but the links are here somewhere

1 Like

Yes I always upload my mac builds to my keybase https://keybase.pub/kd6kxr
My most recent build is @commit g22e

2 Likes

the lensfun is present, it seems that RT that can’t locate it; even though Lensfun is in the correct location

thank you

thanks - much better your Mac builds worked. that’s saved me a lot of time - thanks

sharing this from @HIRAM

https://keybase.pub/kd6kxr

the one with “…g22e…” in build ref worked for me

Out of curiosity, are you on Catalina?

Hi, it’s Mojave

Thank you, I had just noticed you mentioned that in an earlier comment. With 5.8 there was a change affecting all macOS, that is the app must reside in /Applications due to what is called “App Sandboxing”. This is an optional security feature for many years, but is a requirement of Catalina. I was wondering if that may have been an issue previously, for what it’s worth.