Natron couldn't start with amdgpu-pro in Ubuntu 18.04

(graphic2017designer) #1

Hi,
Thanks all.After install Amdgpu-Pro on Ubuntu 18.04 Natron unable to start with error for snap version

Natron Version 2.3.14
Copyright © 2013-2018 INRIA and Alexandre Gauthier-Foichat

Use the --help or -h option to print usage.<<<
/usr/share/libdrm/amdgpu.ids: No such file or directory
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: radeonsi
/usr/share/libdrm/amdgpu.ids: No such file or directory
mesa: for the -simplifycfg-sink-common option: may only occur zero or one times!
mesa: for the -global-isel-abort option: may only occur zero or one times!
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: radeonsi
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
Error while loading OpenGL: GLX: Failed to create context
OpenGL rendering is disabled.
GLX: Failed to create context
GLX: Failed to create context
Qt: Session management error: None of the authentication protocols specified are supported
Info: init.py script not loaded (this is not an error)
Info: initGui.py script not loaded (this is not an error)
/usr/share/libdrm/amdgpu.ids: No such file or directory
mesa: for the -simplifycfg-sink-common option: may only occur zero or one times!
mesa: for the -global-isel-abort option: may only occur zero or one times!
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: radeonsi
/usr/share/libdrm/amdgpu.ids: No such file or directory
mesa: for the -simplifycfg-sink-common option: may only occur zero or one times!
mesa: for the -global-isel-abort option: may only occur zero or one times!
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: radeonsi
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
GLX: Failed to create context

Also couldn’t start with appimage and normal version from website.

Looking forward to feedback and support.

Best Regards,
Marcos

(Mica) #2

For the snap, you’re probably getting confinement issues. Snap packages are sandboxed.