No Access to C: Drive on RT 5.6 on Windows 10

(Brian A.) #1

I’m unable to access the C: drive with RT 5.6 on Windows 10. Wither trying to select the C: drive for save destination or selecting the GIMP installation. Working OK on 5.5

Everytime I select the C: drive I get the following error:

Error when getting information for file “C:\pagefile.sys”:Input/
output error

When I try to specify the Photoshop installation folder, I get an error
#2

@Wickster Welcome to the forum!

Looks like an Windows OS error to me. Could you provide some more details?

– How are you saving? With the Save dialog in the Editor or the Queue?
– Does it happen when you click on “Local Disk (C:)” or during the actual save?

(Roel) #3

This has been reported in the past, but I’m unsure if there was ever a complete fix: https://github.com/Beep6581/RawTherapee/issues/4946
@heckflosse?

#4

I don’t have 5.6 installed so I installed the latest dev. I don’t get this problem. How do I enter verbose mode?

(Ingo Weyrich) #5

Set

Verbose=true

in options file

(Brian A.) #6

Thanks for the quick replies. And sorry for my late reply.
This happens everytime I click the C: drive icon inside RT. It doesn’t matter whether I’m just trying to set the location of GIMP/Photoshop in the settings menu or just trying to set a destination folder inside the batch queue tab. It just gives me that error everytime I click on the C: icon inside RT.

I’ll try uninstalling and installing and also try a dev RC build tomorrow and report back here.

(Morgan Hardwood) #7

Random thought, did you give some sort of administrative or heightened permissions to 5.5 but not to 5.6?

(Brian A.) #8

Here’s some screenshots from the settings > GIMP installation select screen and from the Select destination folder in the Queue screen.


I just installed it normally, but I’ll try to set to run in Admin mode also and report back here.

(Morgan Hardwood) #9

What’s so special about your C:\pagefile.sys that doesn’t affect others? How big is it? What are its permissions?

(Ingo Weyrich) #10

Maybe related:

2 Likes
#11

Makes sense. It wasn’t a part of the options file, so I wanted to double check. Does case matter BTW?

(Brian A.) #12

Thanks again everyone. I think I solved it.
At first I have it run as an Admin and that didn’t really do anything. I also tried installing a development build and I still got the same error.

What worked is that I went to Windows 10 performance settings and moved the Pagefile from the C: drive to the D: drive. After restarting, selecting the C: drive started working again. Maybe it was a corrupted pagefile, but RT was the only one having this error.

Again, thanks so much.

#13

Cool. Just be aware that an update may potentially create a new page file under C: or move the location from D: back to C: I suggest you verify after each Windows update.

I doubt that the page file is corrupted. It is basically used for swap. The issue that @heckflosse linked is probably closer to the real cause.