No right click + Mac catalina

Hi there,

I don’t know if I’m losing my mind but I’m unable to right click in siril. E.g I’m in the red channel and I want to remove a pixel for pixel extraction, it doesn’t register it. If I have selected the image to crop, I can’t right click to access any menu.

I don’t know what I’m doing wrong? I’m losing my mind.

Thanks!

I’ve been using SiriL on Catalina for a year now and I never have any problem with the right click. On which version of SiriL are you?

It’s so bizarre. I’m new to all of this and everything works but right click.

I’m on v. 0.99.8-1 and I tried the prev version too (.4 I think?).

I’m on a Macbook pro - tried using my trackpad and an external mouse. It just doesn’t register the click. If I left click say in background extraction it adds the pixel, but if I right click on a pixel to remove it doesn’t do anything. Then attempting any right clicks for contextual menus it doesn’t do anything too.

I’m just not sure how to resolve this or what to test?

I’m not sure to understand but right click will never remove any pixels.
I’m wondering what you try to do in fact.

Sorry bear with me on this.

Following the tutorial, I was going to do background extraction but exclude the nebula area;this tutorial- Siril - Tutorial for a complete processing of astronomical images with Siril and its scripts
To remove the nebula, I’d right click on the “green squares” produced to not do background extraction. I should have said samples not pixels. My apologies for the confusion.

Following this, even excluding the background extraction process - if I’m doing it completely wrong. I can’t right click still. I am assuming it’s me specific :-/ and no one else having an issue.

image

Are you on the RGB channel ? If yes, that does not work. This is for visualisation only.

Thanks,

I’m in the separate channels, Siril will alert if you’re in the RGB channel. I’m at a loss on why/whats happening. :frowning:

Please could you shoot a small video on what you are trying to do?