Noise Reduction negated on export

Hi - first time poster. I’ve been using RawTherapee for a few months now.

First, some specifications:
RawTherapee 5.8
macOS 10.15.6
Sony .ARW from a7R IV

I noticed that my exported image (all formats and bit depths) retains the noise that I got rid of using the Noise Reduction tool.

This was a digitized negative, so I’m using the Film Negative setting (which only seems to work with the .ARW with all Raw Black Points at their minimum -2048, but that’s another topic, I suppose).

I’m happy with the image at 100% in RawTherapee, but the noise returns after export.

Here is a link with the .ARW, PP3, and an exported 8-bit TIFF:

It doesn’t look like anyone has mentioned this exact same topic - was wondering if anyone has encountered this!

@OAOV Interesting find, thank you for bringing it up. I can reproduce it. @rom9 Do you have a clue?

OAOV, I don’t know why you need to set the raw black points to something other than 0. I get a perfectly acceptable result with the default settings (except for the noise that doesn’t go away).

_DSC0101.jpg.out.pp3 (13.5 KB)

1 Like

Hello @OAOV , thanks for testing!

I’ve noticed this also happens when you export the positive image (film negative tool disabled), if you stretch the image levels, for example using the Tone Curve 2. Here’s an example:

Exported TIFF on the left, RT on-screen preview on the right. Notice the chroma noise on the left.

However, the exported tiffs doesn’t have the same amount of noise as if they were processed with denoise disabled altogether (you can try exporting both versions and subtract them in Gimp).

My guess is that there is always a very very subtle difference between the preview denoise and the exported denoise. The filmnegative tool just makes it more evident because it has to stretch image contrast a lot.

I’m currently working on the new version of the filmneg tool, which works after demosaic. Maybe this could also benefit this particular issue, i’ll give it a try…

1 Like

If I’m not totally wrong this is caused by the very large surrounding area. Denoise is much earlier in pipeline than crop.

@heckflosse: Both @OAOV and I made sure that custom chroma denoise parameters were set instead of full-image automatic. I would assume this would still result in an output that is identical to the preview?

@Thanatomanic I guess it’s caused by this median calculations which gives roughly the median of the sorrounding area in the example file. In this example we have a very large area with completely different noise characteristics than the small cropped subject (the digitized negative) .

1 Like

@heckflosse i gave a look, maybe it’s not related to the actual cropped area (as set with the Crop tool) : in, the RGB_denoise method is called on the origCrop buffer, which contains the currently displayed image.

So, if i understand the code correctly, regardless of the selected crop area, you could even get different noise characteristics if you zoom at 100% or 400% on the same area, or if you resize the RT window (though the difference would be negligible).

Your observation is correct. There are already some github issues about that iirc.

Here’s a simple proof, you can see the difference just by panning the “interesting” part of the picture towards the edge of the viewport:

the more “back” you include in the viewport, the more chroma noise shows up in the gray area.
Note however that i had to push levels really hard. These are very subtle differences…

1 Like

Thanks for taking a look at this, everyone. I’m going to continue to try to experiment and see if I notice anything else!

Interesting - thanks for checking about the raw black points. When I start from scratch with a neutral profile, then turn on the Film Negative tool, I get this:

Even without the values set, I usually see some some sort of positive image (although those have all been .IIQ files).