Not stuck building RT from source


(Andrew) #1

I was recently at a portrait shooting event with amateur models so before starting to process what I took, I thought it was about time to update my RT. The building earlier today went without a hitch, and I thought such a contrast with the recent gimp activity, so I am saying Thanks to all the RT people for keeping it working, documenting what to do in Rawpedia, etc.

Here is what I produced tonight -


(I see the file details in the left hand pane here include “690x609” though the file on my machine is 2000x1768 pixels ?)

I noticed a few things using this new RT -

  1. I run it from a Terminal window (Ubuntu) and several messages appeared as I worked,
    Empty input file
    blockdenom vanishes
    blockdenom vanishes
    blockdenom vanishes
    blockdenom vanishes
    Premature end of JPEG file
    JPEG datastream contains no image

The jpeg ones are not new. Haven’t seen blockdenom before, I think that was when switching between Amaze and Amaze+VNG4.

  1. I see adobeRGB is now available as an output profile in its own right, as opposed to “medium”. How different is it from “medium”, if at all?

  2. More importantly, I had a problem with Lab equalizer. I was doing CH but others are affected too. Previously I’m sure that as you cursored over the image, the relevant point was shown on the equalizer grid. But not tonight. And on enabling the pencil and expecting a click on the image to create a point in the grid, it didn’t. Got the same with the HSV equalizer tool. Otherwise the girl would have had more vivid hair!

My Rt is this -
Version: 5.4-918-gae12a41
Branch: dev
Commit: ae12a41
Commit date: 2018-09-29
Compiler: cc 5.4.0
Processor: x86_64
System: Linux
Bit depth: 64 bits
Gtkmm: V3.18.0
Lensfun: V0.2.8.0
Build type: release
Build flags: -std=c++11 -march=native -Werror=unused-label -flto -fopenmp -Werror=unknown-pragmas -Wall -Wno-unused-result -Wno-deprecated-declarations -O3 -DNDEBUG -ftree-vectorize
Link flags: -march=native -flto
OpenMP support: ON
MMAP support: ON


(Morgan Hardwood) #2

That comes from the raw CA correction tool.

No, that comes from your own system, not from RT.

It works fine here. Did you remember to first enable the L*a*b* tool?


(Andrew) #3

Yes, enabled. So cursor positioned but nothing in the grid -


(Andrew) #4

cursor was on the hair


(Morgan Hardwood) #5

Activate the pipette:

screenshot


(Andrew) #6

Thanks @Morgan_Hardwood, yes I hadn’t activated it. The icon has changed since my mid-June version, it was a cross-hair type thing then.

I’ve just been back to my mid-June version and it has fewer profiles, and in particular doesn’t give adobeRGB, so I think the latest build is working a bit differently.

Calling CIECAM people - @jdc ? - something has changed re. drawing custom curves. In mid-June, all was fine in my view. When the cursor got near a point, it changed to a hand, to show you were about to move the point, rather than add a new one. Now there’s just one cursor, so you don’t quite know what’s what. There seems also to be a bug around “first use”. Mid June works fine in that CTRL + click puts the new point on the curve without changing the path. This is really useful for creating a “blocker” so that the effect of further points is localised. Now, the first time you add the second point, the path alters. Subseqeunt CTRL+clicks work ok. If you initialise back to a straight line without points and repeat, the problem is there again I think. So I think there’s a bug. It seems a shame to remove the nice cursor flipping - between hand and ?cross. Why was that done?!

Best regards, Andrew


(Andrew) #7

Issue 4851 created re. Ctrl+Click, https://github.com/Beep6581/RawTherapee/issues/4851