OM-1 raw files supported by Art?

I am thinking about buying the relatively new OM-1 camera. Fore my other camera I use RawTherapee for raw editing, but this is not possible for the OM-1 because RT dos not support the OM-1 camera raw files. In a thread in RT about the OM-1 I read that ART does support this camera, but before buying the camera I want to be sure. Can someone please confirm if this is true (or not)?
Jan.

Yes, if you build with the latest libraw master (like in the prebuilt binaries) it should work

I guess it depends on the build options… A good place to start is:

  1. Download/build ART
  2. Download OM-1 sample from RPU
  3. Try
2 Likes

Thank you. I tried and it worked.

1 Like

Great. However, if you are using art to replace RT, be ready for disappointment. Maybe you know that already, but better safe than sorry :slight_smile:

Yes I noticed already. But I can always go back to RT once the OM-1 is supported. I don’t know how long I will have to wait untill RT supports this camera and I don’t want to wait very long before buying this camera.

I read this thread with great interest since I have an OM-1 and am a Linux user. But I do not manage to get ART to work with the OM-1.
I did compile and install the latest Libraw from github. Then I ran the automated compilation of ART, similar to that of RT. But the OM-1 files still look corrupt. I think that the Libraw ends up in /usr/local/… maybe this is the problem. Does anyone have any tips on what I am doing wrong, or how I should do to get the latest libraw used while compiling?

Hi, you need to set ENABLE_LIBRAW to true when configuring with cmake, and make sure that the proper version of libraw is found. You can check this by looking at the AboutThisBuild.txt file that is generated in the build directory.

HTH

Thank you Alberto,
That solved the problem. I had some problem that libraw was not found. But that was solved by adding the path to the usr/local/lib.