Only one core used


#1

I’m using RawTherapee 5.4 on Windows 7 64-bit. Whenever I do something CPU intense, task manager shows that RawTherapee peaks at 25% CPU usage. It seems like only one core of the quad-core processor (Intel Core i5-750) is used.

Is there anything I can do for proper multi-core support? Thanks :slight_smile:


#2

@ToothFairy Welcome to the forum. You have an interesting username. Unfortunately, multi-core support takes time and effort to implement in the code and also debug. I am not a dev. If you search this forum, many people have pointed this out. Take a look at how the devs responded to this question.


#3

Thank you. Collecting teeth is what I do, photography is a hobby.
I have tried searching the forums and also Google but I was unable to find anything.


#4

Which build are you using, btw? From RawTherapee.com or somewhere else?


#5

It’s from the RawTherapee.com. I don’t know abouts builds, but it says Build type: release. Please let me know if you need any more information :slight_smile:


(Ingo Weyrich) #6

Most of the tools in RawTherapee are multithreaded. But there are also parts which don’t use all cores.
For example there are only a few raw decoders which use all cores (these are sony arw, float dng, phase one iiq, Fuji compressed). Canon cr2 decoder uses 2 cores. Most of the other decoders use only 1 core.

After decoding the raw files, almost all tools use all cores, with the exception of Tonemapping tool and maybe one or two other tools.

Can you tell us which CPU intense tools you use?


#7

I’ve just tried some things like opening photos, switching between them and saving them and now I did see the CPU usage go up way beyond 25%. I’m not sure what I did previously that CPU always peaked at 25% because now I can’t seem to reproduce it. :confused:


#8

As expected here (i5 3570):


#9

It looks very similar here. I don’t know why it seemed to only working on one core earlier. Sorry to bother you!


#10

Windows does a lot of funny business in the background. I wouldn’t be surprised that it wasn’t RT’s fault.