Opencl not starting on my new system

With an NVIDIA RTX 3050 I’m seeing:

[colinadams@fedora ~]$ /opt/darktable/bin/darktable -d opencl [opencl_init] opencl related configuration options: [opencl_init] opencl: ON [opencl_init] opencl_scheduling_profile: 'default' [opencl_init] opencl_library: 'default path' [opencl_init] opencl_device_priority: '*/!0,*/*/*/!0,*' [opencl_init] opencl_mandatory_timeout: 400 [opencl_init] opencl_synch_cache: active module [opencl_init] opencl library 'libOpenCL.so.1' found on your system and loaded [opencl_init] could not get platforms: Unknown OpenCL error [opencl_init] FINALLY: opencl is NOT AVAILABLE on this system. [opencl_init] initial status of opencl enabled flag is OFF. 0.871508 [pixelpipe_process] [thumbnail] using device -1 5.157267 [pixelpipe_process] [full] using device -1 7.957801 [pixelpipe_process] [preview] using device -1 12.063129 [pixelpipe_process] [full] using device -1 12.166743 [pixelpipe_process] [preview] using device -1 20.957876 [pixelpipe_process] [full] using device -1 21.003666 [pixelpipe_process] [preview] using device -1 [colinadams@fedora ~]$

So this line isn’t too helpful:

[opencl_init] could not get platforms: Unknown OpenCL error

any idea on how to proceed further? (darktable 4.1.0 built from git. Running on linux)
Should I turn off Wayland?

Hi,

I do not know about fedora, but debian has this to say:
https://wiki.debian.org/NvidiaGraphicsDrivers#Wayland

Have fun!
Claes in Lund, Sweden

1 Like

Silly me - I hadn’t installed the CUDA drivers which include the opencl.

Working now, thanks to the fine manual.

3 Likes