Output files very, very dark (Solved - User error)


(Homo_erectus) #1

Hello,

I’ve been using RT on windows and macos for a while now without any troubles.

I’m testing out linux to see if I can, finally, give windows the old heave-ho. However I’ve run into an issue that I can’t figure out.

I’m using Ubuntu 16.10 and I installed RT5 using the directions on the RT site. I installed argyll cms and displaycal and I calibrated my display with my colormunki display. I pointed RT at the monitor profile that displaycal made and set the rendering intent to relative colormetric. I set the working color space to AdobeRGB1998 and the output color space to the same. I copied the common icc profiles from my windows machine. I basically set everything up in linux exactly as I do in windows.

Everything seems to be in order. Images that I process on the linux machine look great both in RT and when I export to jpg and look at them in gwenview, geeqie, gimp and whatever image viewer ubuntu uses by default. They look great on that one computer but when I view them on my windows computer they are like 80% darker and like 90% more contrasty than they appear on the linux machine.

I’ve tried:
recalibrating
recalibrating and using the exact same settings as I use on the window machine rather than the displaycal defaults
making jpgs in different color spaces: sRGB, AdobeRGB1998
Viewing the jpgs in different programs on the windows machine; Photoshop, Adobe Bridge, Affinity Photo

No matter what I do, images that I process on the linux machine all have this issue.

I’ve worked in the print industry for many years and I know my way around color management, at least in windows and macos. I think i have everything set up right in linux but there’s always the chance I’ve missed something elementary. In fact I hope it’s something elementary so it’ll be easy to fix!

I’m out of ideas at this point though. Can anyone give me some ideas for what else to look at?

The computer itself has an nvidia gtx460m, 8 gigs of memory, a second gen core i7, and some crazy off brand lcd. I am using the Nvidia drivers, rather than the open source drivers.

I’m thinking my next steps are to try it all using the open source driver, to connect an external monitor, calibrate it and try processing a few images on it. Maybe make sure that RT is using a sane gamma setting for output? And that’s all I’ve got. Maybe try an older version of RT to see if the problem persists?

Oh, also, images processed in windows and macos look fine on the linux machine when viewed in a color managed program.


(Ilias Giarimis) #2

Why not share one of your output files that has the mentioned problem :wink:


(Homo_erectus) #3

I just processed an image in RT on windows and then saved the settings as a profile. Then I imported that profile and assigned it to the same picture in RT on the linux machine. It looked terrible on screen but the output file is identical to the version created in windows. IE this is not an RT problem but is either the monitor, video card or calibration.

My apologies for wasting time.


#4

Any reason you changed the working profile to something other than ProPhoto? http://rawpedia.rawtherapee.com/Color_Management#Working_Profile


(Homo_erectus) #5

Thank you! I haven’t read the entire manual yet.

Also, for anyone else who might run into an issue like this. The solution was that the monitor and calibration device had not warmed up enough before I started the calibration process.

DisplayCal clearly warms about waiting 30 minutes before calibration and that is the freaking truth. I recalibrated last night after letting the machine run for an hour or so and it is spot on now.

Thanks everyone!