Photometric Colour Calibration has me confounded, please help to troubleshoot.


Firstly a huge thank you to the developers & contributors of Siril, it has been a godsend for me & I use it exclusively for all my preprocessing & initial post processing. In particular the photometric colour calibration has been a game changer for me. The trouble is I can no longer get plate solveing / photometric colour calibration to work. I am am using v1.0.0.0 & until recently it was successful almost 100% of the time but now it won’t even calibrate images it has previously been successful with. I’m baffled, surely I’m doing something wrong. In desperation I uninstalled/ reinstalled Siril & it plate solved immediately as it has done in the past on a particular image. But next image…no luck :neutral_face: & following multiple attempts, all failed with: “the image could not be aligned with the reference stars”. I’ve researched as much as I can on the problem & I’m aware other users have had similar issues but surely it must be user error on my part if it is failing 100% of the time. Any help would be gratefuly accepted & thanks in advance. I’ll upload an image of NGC3372 which was successfully plate solved by & previously by Siril as a test case.

Hi Tony,

hard to say from the screenshot you’ve posted, as the jpg must have undergone some serious compression. Could send a share to the fits file, together with pixel size and focal length, so that we can have a look?



Hi Cissou,

thank you for your reply. I’m new to this forum, can you tell me how to share the fits file?
Focal length is 1076mm & pixel size is 4.88. Here is a link to the result at Astrometry dot net;


We meant your original picture.
Because of course there are no issue doing this on an already solved image.

Hi Lock,

I thought you access the original as well from the link.
how do I upload or share the original fit file? It’s 395mb.


A service like wetransfer allows you to upload large files.

Thank you Lock. :+1:

Here’s the link; WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free

Hi again Tony,

phometric calibration does work as expected in Siril 1.0.0 so I’m not sure what is going wrong on your end:

(your picture is glorious BTW!)



1 Like

:blush: I’m glad you like the image Cissou. Still not working at my end, it will search & find the DSO ok but regardless of which search result I choose it will fail every time. As soon as I press the “OK” button at the bottom I immediately get the Fail notification. It’s like it doesn’t even try. :man_shrugging:. I’ll reinstall again to see if that rectifies the problem as it did before.


What operating system are you using?

Not in front of the computer right now but not sure i was getting more than one object to select.
The steps i’ve been going through are:

  • Load your image as is (no histogram transformation, stretch, no selection in the picture or the like)
  • Type eta carina in the search box
  • Press Find
  • Select the object (doesn’t matter that much in fact, it’s just a matter of specifying roughly the center of the image. Differents catalogues will return slightly different values but all RA/Dec should match from one to the other).
  • Fill in focal length and pixel size
  • Press OK
    Anything you may be doing differently?
    Maybe you could paste the part of the log related to this here, see if we can spot anything peculiar?

Hi Vincent,

Thank you for your interest. My PC configuration is;

Intel(R) Core™ i7-4790K CPU @ 4.00GHz
Installed RAM 32.0 GB
System type 64-bit operating system, x64-based processor
Windows 10 Home Version 21H2.


Please, disable your AV for testing purpose and retest the color calibration.

My procedure is exactly as you have described Cissou. Since my last post I reinstalled Siril again & plate solving / photometric calibration is working again so I believe we have ruled out any problem with my data, my procedure & Sirils ability. Reinstallation rectifies the issue (for how long remains to be seen), I believe the problem is related to the OS. I have looked at the system event viewer but couldn’t find any evidence relating to Siril there. How to diagnose this any further within the OS is beyond my capabilities but maybe the information from this thread can help someone more tech savvy to isolate the issue.


Yes I did try that Lock. It made no difference unfortunately. I reinstalled Siril which has solved the problem for the time being at least. My belief is that the OS is responsible somehow.


Could you show me your output logs?

Here is a screenshot of an image I just loaded which Siril plate solved successfully after the reinstall.
I’m not sure it’s possible access any output logs from any earlier sessions prior to the reinstall.
Unfortunately I didn’t save any from the failed sessions.


I thought I’d post an update to share my expeience with this issue & thank Cissou & Lock for their interest and support. My last post showed plate solving worked again after reinstalling Siril, following that I closed Siril & opened it again a few hours later. As you might have guessed plate solving was no longer working.

If look at the output log only 2 seconds elapse before getting the “Fail” notice, perhaps this is something of note. So after several failed attempts I reinstalled Siril again & plate solving worked like a charm every time & continued to do so as long as I kept Siril open. When I restart Siril plate solving fails again. This is the case consistently. So what happens to Siril after it is closed to prevent plate solving working when it is reopened again? Your guess is as good as mine. Is it my computer or is my experience consistent with other users with the same OS? All I can say is that reinstalling Siril solves the issue 100% of the time. Perhaps someone else with the same problem can chime in?


I am on windows 11 and have no issues. Just an informational post here