Preview locked at 19,87% and some odd spellings


#1

Salut!

Linux Mint 19 - CInnamon.
G’MIC-Qt for Gimp 2.10 Linux 64bits - 2.3.4.

Preview seems locked at 19,87%. Preview settings all greyed out.
In drop-down Preview mode, output(s) are mis-spelled as ouput(s).

Cordialement,
Claes in Lund, La Suède


#2

Hello Claes,

In “Settings” you can check: “Always enable preview zooming”.

But I don’t know if this helps you with your problem.


(paul matthijsse) #3

Hello Claes, I confirm this zoom behavior. In other views the preview is locked at 100% - no smaller percentages available.
Do what Iarga says: check Always enable preview zooming, that seems to be the solution.


(G'MIC staff) #4

Indeed, we decided to lock the preview zoom by default in recent release 2.3.4.
It can be unlocked as you describe, by checking the Always enable preview zooming tickbox in the settings dialog.

The main reason we did that is, we got several times complaints about the fact that for many filters, the previewed image was not accurate and didn’t reflect the final result (after the filter application). 99% of the time, this is due to the user changing the zoom level in the preview window.
Developers already know how hard is it for ‘complex’ filters to manage rendering an accurate preview. This becomes nearly impossible if the user plays with the preview zoom factor.

So, now by default we just allow only changing the zoom factor if we know that the preview will be still accurate. If you change this default behavior, you know that there is a risk of getting non accurate previews :slight_smile: