Problem: Camera Manufacturer shows in all exported photos

When I export a photo, the camera manufacturer now is automatically mentioned in the “comments”. Not in the “normal” exif data, but in a field that has been empty so far.

If I hand the photo to flickr, the photo comment is automatically filled with “NIKON CORPORATION” or “Fujifilm SP500” if I use the scanner. Same in wordpress, where the image title and caption both are filled with “NIKON CORPORATION” (all caps).

This is annoying AND it’s new (since 3.6). Feature or bug: where do I turn it off?

I don’t know why this did appear, but there is a method to prevent to export a given tag.
First, with exiv2, determine the exact name of that tag.
Then, in the metadata export configuration, add it to list “per metadata settings” and let the formula empty.
Just seen this info is in the tooltip but not in the doc. I’ll add it.

“NIKON CORPORATION” comes from the tag “Exif.Image.Make”.

Could you please share the output of :
$ exiv2 -PEXI file | grep NIKON
for both the raw file and the exported file ?

From the NEF

stefan@outpost:~/Photos/2021/07/03$ exiv2 -PEXI SAS_7213.NEF | grep NIKON
Exif.Image.Make Ascii 18 NIKON CORPORATION
Exif.Image.Model Ascii 11 NIKON D610

from the final jpg

stefan@outpost:~/Bilder/2021$ exiv2 -PEXI Elo_SAS_7213.jpg | grep NIKON
Exif.Image.ImageDescription Ascii 18 NIKON CORPORATION
Exif.Image.Make Ascii 18 NIKON CORPORATION
Exif.Image.Model Ascii 11 NIKON D610
Exif.Photo.UserComment Undefined 25 NIKON CORPORATION

1 Like

Very strange indeed…

Exif.Image.ImageDescription and Exif.Photo.UserComment can be set from Xmp.dc.description, but not both at the same time… (dixit the code)

I cannot reproduce your problem with the current master.

Probably a stupid question. Would you have any formula defined in export metadata settings ?

I don’t even know what a formula or export metadata settings are …

I recently exported some photos directly out of dt as .jpg and the problem did not occur. Clearly the GIMP in adding this information somewhere in the metadata …


OK, the passage through GIMP can change the situation.
If you want to get rid of them, go to export/preferences… (presets menu), add the too tags in the formula list, letting the formula empty. Normally these tags won’t appear any more in the exported images.

1 Like

I think, he refers to this part

You can access the preferences via the hamburger menu and check what you are actually eporting