Problem framerate 48fps


(Dave Callagahan ) #1

Hello everyones,

I’ve problem with the preview framerate.
I’ve got HD shots( 1080p) from Blender in 48 fps, and export in sequence PNG images (2-3Mo /images). But Natron won’t reach 48fps, even with proxy, even with Turbo mode. The maximum I have is around 36 fps (appear in orange, too slow) with the turbo mode (without, it’s more 23 fps). I don’t know if the problem come from Natron prefs/DiskCache or something with the export png (files too big)
If anyone had an idea, i’m pleased to listen
thanks
DaveC


(Frédéric Devernay) #2

writing PNGs takes time.
As a baseline, you can compare with conversion of a single HD shot to PNGs with the ffmpeg command-line (ffmpeg -i video.move frame%04d.png -hide_banner)
Natron works with floating-point format, so it does more work than ffmpeg:

  • read the frame
  • convert to linear floating-point format
  • process through the graph
  • convert from linear to 8-bit or 16-bit ints
  • encode

(Mikhail) #3

Hi I think if you have a lot of ram you can get 48 fps on playback
i made test with Hd footage - jpg - 1.3M per frame - 598 frame - it takes 16 Gb Ram
bat then all sequence was in ram it’s play 48fps
as for me I usually pre render sequences and used DJW or PDPlayer - for play long sequnce
but for check small things I setup in preferences - use all available ram - and check that time line green on full length then preview is plaing


(Dave Callagahan ) #4

Hi,
thanks for your answers.
So it’s possible but I don’t know how.

I tested some conversion in video file:

I tried to convert the sequence PNG images to a video file with FFmpeg, but Natron won’t open the video file. “Cannot read the file”. I tried with AVI, MP4 (container) and codec like x264, xvid, x265, openjpeg, … but don’t work at all.
So, I tried export directly with Natron. Export PNG to MP4 with x264 (4Mo for 255frames, ok). Reading file works, but always to slow (37 fps max).
With Blender, export the images in video file AVI jpeg (too ugly compression), or MP4 h264, Natron can’t read file. Error reading like FFmpeg conversion.

I have 25Go for RAM memory cache in Natron, and maximum 15Gb in playback cache and Disk Node cache.

[edit]
Ok, i update my post because I just try a simply test. A noise in Natron, and the playback can’t be read in 48fps. Natron stuck at 30fps. Maybe it’s not the files, but more Natron the problem.