Problems with transparency

After exporting my video file, i put it in SLOBS, and found that the background was NOT transparent, but instead Black. The transparency box is ticked: image and the background on my merge node is a completely transparent 1920x1080 png file ( i made sure of this). Any help?

What is your exported format? It should be MOV. Have you tried to import the video back to Natron and check the transparent?

The transparency box you show here is a viewer option, all it does is display a grid where there is transparency in Natron’s viewer, it has no effect on what is exported.

If you exported to H264 your file will not have transparency because H264 does not support an alpha channel. Personally I would recommend exporting as an EXR sequence or Pro res 4444, both of those support an alpha channel.

Please screenshot your write node settings and post here.

OBS doesn’t support EXR though. For video source, it also doesn’t support image sequence.

1 Like

Thank you for your suggestions. However, my write node IS an MOV file, and the alha box is ticked. Here are my write settings.


As Hank recommended, you should change the codec to pro res 4444.

1 Like

4444 or 444?

Nope, don’t care, i did it, thanks so much for the support!


Sorry, it’s a 4444.