Rapid Photo Downloader 0.9.20 is released

This release contains some important updates to help with desktop integration, and the ability to change the user interface language independently of the system language. Like the last release, you’re better off running the install.py and not using the built-in updater because the install script can install system packages that the updater cannot.

openSUSE 15.2

opensuse-launcher

Pop!_OS with dash to panel extension:

popos-integration

If you package this application for a Linux distribution, please note the last part of the changes list below.

  • Added support for program icon progress bars and badge counts on any desktop
    that supports the Unity LauncherEntry API, not just Ubuntu Unity or Gnome
    running under Ubuntu. (The Unity LauncherEntry API is used by desktops other
    than Unity and Ubuntu Gnome, e.g. KDE, Dash to Panel.)

  • Added missing property StartupWMClass to the program’s desktop file. It’s now
    possible to add the Rapid Photo Downloader launcher as a Favorite to the
    Gnome Shell dock and not have it appear as a duplicate entry when the program
    runs. This fix also enables program icon progress bars and badge counts under
    Gnome Shell extensions that support them.

  • Implemented feature request in bug #1810102: cannot change language in
    program preferences. You can now specify the language you want the user
    interface to display in regardless of the system locale setting.

  • Fixed problems in setup.py. Made requirements.txt more conformant.

  • Better handle missing ExifTool on startup.

  • For distribution packagers, this release adds new package dependencies. The
    SVG module for Qt 5 must be listed a required dependency, or else Rapid Photo
    Downloader’s SVG assets will fail to display (this has been happening under
    Pop!_OS, for example).

    For openSUSE:

    • typelib-1_0-UnityExtras-7_0
    • typelib-1_0-Unity-7_0
    • typelib-1_0-Dbusmenu-0_4
    • typelib-1_0-Dee-1_0
    • python3-babel
    • libQt5Svg5

    For Debian:

    • gir1.2-unity-5.0
    • python3-babel
    • libqt5svg5

    For Arch:

    • qt5-svg

    For Fedora:

    • qt5-qtsvg
3 Likes

I don’t see any imports for this typelib. Normally our typelib Requires for a package are auto generated.

I saw it in Leap 15.2. Unsure about Tumbleweed. I have literally no idea what it adds to the base typelib-1_0-Unity package!

no what i mean is … shouldnt your code load the unityExtra typelib somewhere?

These are the key lines of code:

import gi
gi.require_version('Unity', '7.0')
from gi.repository import Unity

I don’t know what unity extra typelib does as compared to its parent package. I thought it needed to be included to make sure the Unity API works as expected. If it does literally nothing then I suppose it might work without it. Do you want me to check to see if it is needed, as best I can? (i.e. run the program with the unity extra package removed).

that would be good yes. fewer dependencies are always better :slight_smile:

my test package is here home:darix:branches:graphics/rapid-photo-downloader

@asn more toys! :smiley:

Is that a repository or a package? Could you please tell me how to install the package from the command line? Thanks.

$ zypper ar obs://home:darix:branches:graphics home:darix:branches:graphics
$ zypper in --from home:darix:branches:graphics rapid-photo-downloader

The extras package is definitely required. Without it get:

** (python3:3235): WARNING **: 18:07:24.545: Failed to load shared library 'libunity.so.9' referenced by the typelib: libunity.so.9: cannot open shared object file: No such file or directory
ERROR    An unhandled exception occurred
ERROR    Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/raphodo/rapid.py", line 902, in initStage4
    desktop_launcher = Unity.LauncherEntry.get_for_desktop_id(launcher)
gi.repository.GLib.GError: g-invoke-error-quark: Could not locate unity_launcher_entry_get_for_desktop_id: (null) (1)

Adding it back to the package

Thanks. It starts now. I have no idea why it segfaults on exit, however. Those are above my skill level.

Also no idea which dependency is outputting to the command line “RW2 IMAGE” or “ORF IMAGE” etc. Don’t know if it’s exiv2 or ExifTool or something else. It’s not my code, as best as I can tell!

I’m trying to install on Debian 10 using the install.py script, and the installation fails with
“The following package is not known on your system: girl.2-unity-5.0”

This isn’t in the Debian repos. I think it’s an Ubuntu package. Any suggestions?

the openSUSE package is now in the graphics project and on its way to tumbleweed and 15.2

Sorry about that. Seems Debian does not package anything from libunity and has not done so for years, if ever.

Which is most unfortunate because libunity provides features that are independent of unity that desktops like KDE can use.

Delete the current install script, and do this to get an updated install script. Let me know if it works for you (it should):

wget https://bazaar.launchpad.net/~dlynch3/rapid/zeromq_pyqt/download/head:/install.sh-20160314191008-iy73j6kjbhwpk0t9-1/install.py

JFYI: we figured out why our unity typelib package had missing requires. (dee/dbusmenu typelib, libunity) and now it seems you dont need UnityExtra. we will test again when we have updated packages for libdbusmenu and libunity (and its typelibs)

Cool thanks!

Worked perfectly! Many thanks for your speedy help!

mac

1 Like

Program has worked without problems for months, but I had two problems today.

First one is that it wants to re-index the timeline, and thinks none of the photo’s on my SD card have been loaded before. This was before I updated to 0.9.20, but the latest version also wants to do this.

Second one: the 0.9.20 version has a problem with fonts on font-sizes. the menus in the bottom and right side are not fully shown. (it also affects the settings dialog).

-peter

Please be a LOT more specific. Are you downloading from a camera or an SD card reader? What do you mean, exactly, by “have been loaded before”? Do you mean have had thumbnails generated, or do you mean you’ve downloaded them before and the program is not picking that fact up, or something else?

Screenshot illustrating the problem, thanks. Also, attach the log files. In which case, it’s better to open a proper bug report, as discussed here: https://damonlynch.net/rapid/help.html