Rapid Photo Downloader on ARM?

Dear Damon,

to start with, a massive thanks for your brilliant piece of software, I don’t know how I ever managed without it!

I was wondering if there is any way/hope of getting RPD to work on ARM devices? I have a new Pinebook Pro with an ARM based Rockchip RK3399 SOC running Debian 10.

I spend a lot of time away from home and would love to be able to download my photos to the Pinebook Pro while away from my main machine.

Stay safe and keep up the good work!

Have you tried running the installer? Its python, so it should run OK on arm.

It is packaged in Debian, in stable / testing / unstable. I do not own an ARM laptop so I have never tried it. As expected the package in stable is many years old.

Thank you for the very quick reply!

I feel quite silly now, it is indeed packaged and it installed perfectly from GNOME Software… :blush: It’s version is 0.9.13, from November 2018.

I had just gone straight to the install script like I always do and didn’t even think of checking the repositories…

Thanks again!!

Thanks paperdigits,

as you can see above I went straight for the installer but that failed.

Just in case there might be an easy fix, I’ll (try to) post the terminal output here:

$ python3 install.py
Detected Linux distribution Debian 10

pip will be upgraded from version 20.1 to version 20.1.1

setuptools will be upgraded from version 46.2.0 to version 46.4.0
These Python3 packages will be upgraded for your user (i.e. not system-wide): pip, setuptools
The following command will be run:

/usr/bin/python3 -m pip install --user --upgrade pip setuptools --disable-pip-version-check

Collecting pip
Downloading pip-20.1.1-py2.py3-none-any.whl (1.5 MB)
|████████████████████████████████| 1.5 MB 5.5 MB/s
Collecting setuptools
Downloading setuptools-46.4.0-py3-none-any.whl (583 kB)
|████████████████████████████████| 583 kB 15.9 MB/s
Installing collected packages: pip, setuptools
Attempting uninstall: pip
Found existing installation: pip 20.1
Uninstalling pip-20.1:
Successfully uninstalled pip-20.1
Attempting uninstall: setuptools
Found existing installation: setuptools 46.2.0
Uninstalling setuptools-46.2.0:
Successfully uninstalled setuptools-46.2.0
Successfully installed pip-20.1.1 setuptools-46.4.0
Restarting script using /usr/bin/python3
Downloading https://launchpad.net/rapid/pyqt/0.9.24/+download/rapid-photo-downloader-0.9.24.tar.gz (8.15 MB)
0% [##############################] 100% | ETA: 00:00:00
Total time elapsed: 00:00:01
Querying package system to see if an older version of Rapid Photo Downloader is installed (this may take a while)…
Checking if previous version installed with pip…

Installing application requirements…

Ignoring pyzmq: markers ‘python_version < “3.6”’ don’t match your environment
Ignoring typing: markers ‘python_version < “3.5”’ don’t match your environment
Ignoring scandir: markers ‘python_version < “3.5”’ don’t match your environment
Looking in indexes: https://pypi.python.org/simple/
Requirement already satisfied: psutil>=3.4.2 in /usr/lib/python3/dist-packages (from -r /tmp/tmp0ocdql3e (line 4)) (5.5.1)
Requirement already satisfied: gphoto2>=2.2.0 in /home/ernst/.local/lib/python3.7/site-packages (from -r /tmp/tmp0ocdql3e (line 5)) (2.2.2)
Requirement already satisfied: pyzmq>=16.0.2 in /usr/lib/python3/dist-packages (from -r /tmp/tmp0ocdql3e (line 7)) (17.1.2)
Requirement already satisfied: pyxdg>=0.25 in /usr/lib/python3/dist-packages (from -r /tmp/tmp0ocdql3e (line 8)) (0.25)
Requirement already satisfied: arrow>=0.9.0 in /usr/lib/python3/dist-packages (from -r /tmp/tmp0ocdql3e (line 9)) (0.12.1)
Requirement already satisfied: python-dateutil>=2.2 in /usr/lib/python3/dist-packages (from -r /tmp/tmp0ocdql3e (line 10)) (2.7.3)
Requirement already satisfied: rawkit>=0.6.0 in /home/ernst/.local/lib/python3.7/site-packages (from -r /tmp/tmp0ocdql3e (line 11)) (0.6.0)
Requirement already satisfied: PyPrind>=2.9.4 in /home/ernst/.local/lib/python3.7/site-packages (from -r /tmp/tmp0ocdql3e (line 12)) (2.11.2)
Requirement already satisfied: colorlog>=2.6 in /usr/lib/python3/dist-packages (from -r /tmp/tmp0ocdql3e (line 13)) (4.0.1)
Requirement already satisfied: easygui<=0.97.4 in /usr/lib/python3/dist-packages (from -r /tmp/tmp0ocdql3e (line 16)) (0.96)
Requirement already satisfied: colour in /home/ernst/.local/lib/python3.7/site-packages (from -r /tmp/tmp0ocdql3e (line 17)) (0.1.5)
Requirement already satisfied: pymediainfo>=2.2.0 in /home/ernst/.local/lib/python3.7/site-packages (from -r /tmp/tmp0ocdql3e (line 18)) (4.2.1)
Requirement already satisfied: sortedcontainers in /usr/lib/python3/dist-packages (from -r /tmp/tmp0ocdql3e (line 19)) (2.0.4)
Requirement already satisfied: requests in /usr/lib/python3/dist-packages (from -r /tmp/tmp0ocdql3e (line 20)) (2.21.0)
Requirement already satisfied: tornado in /usr/lib/python3/dist-packages (from -r /tmp/tmp0ocdql3e (line 21)) (5.1.1)
Requirement already satisfied: tenacity in /home/ernst/.local/lib/python3.7/site-packages (from -r /tmp/tmp0ocdql3e (line 22)) (6.2.0)
Collecting pillow>=5.1.0
Using cached Pillow-7.1.2.tar.gz (38.9 MB)
Requirement already satisfied: Babel in /usr/lib/python3/dist-packages (from -r /tmp/tmp0ocdql3e (line 25)) (2.6.0)
Requirement already satisfied: setuptools in /home/ernst/.local/lib/python3.7/site-packages (from pymediainfo>=2.2.0->-r /tmp/tmp0ocdql3e (line 18)) (46.4.0)
Requirement already satisfied: six>=1.9.0 in /usr/lib/python3/dist-packages (from tenacity->-r /tmp/tmp0ocdql3e (line 22)) (1.12.0)
Building wheels for collected packages: pillow
Building wheel for pillow (setup.py): started
Building wheel for pillow (setup.py): finished with status ‘error’
Running setup.py clean for pillow
Failed to build pillow
Installing collected packages: pillow
Running setup.py install for pillow: started
Running setup.py install for pillow: finished with status ‘error’
Received error code 1
Failed to install application requirements: exiting.

Version 0.9.13 is really a very old version. Let’s try to figure out why the Python package Pillow is not installing on your system. Do this:

python3 -m pip install -v -U pillow

And copy and paste the error output here.

over 2300 lines of output from that! :open_mouth:

When I try to post that I get the following warning:
“Body is limited to 50000 characters; you entered 680667.”

I’ll therefore upload the output in a text file.

pbp.txt (664.6 KB)

Is this package installed?

libjpeg62-turbo

It is, newest version (1:1.5.2-2+b1).

You could upgrade to a distro that ships newer versions. instead of sticking to old distros :stuck_out_tongue:

As ARM based laptops are not yet mainstream there are not a lot of options for the Pinebook Pro if you want an proper installer that supports full disk encryption instead of a a ready made image.

I tried to install Manjaro but failed so opted for Debian, which is also more in my comfort zone as most of my Linux experience is with Ubuntu based distributions so far. I could have opted for Debian 11 Bullseye but decided that being on an ARM based laptop with a hacked 5.5 kernel is bleeding edge enough for me. This is to be my daily driver while being from home for weeks at the time , most of the time. I greatly value stability.

I’m happy to have 0.9.13, getting the installer to work would be a bonus.

It might be the package is so old that recent versions of pillow simply fail to build against it.

Try installing the Debian package python3-pillow and then retry the install.py script.

Brilliant, that did the trick, running 0.9.24 now!! :partying_face: Thank you so much!

I’m glad it worked. A future enhancement to the script might be to give the option of prioritizing the installation of distro packages over packages from PyPi.