Raw Therapee 5.5 won't set Photoshop as External Editor...


(Adam) #1

Hello!

Am using Raw Therapee 5 in Windows 10 and am trying to setup Photoshop CS6 as my external editor, but no matter what string I put in, I universally get the “Can’t Start Editor” error (even when Photoshop is already running). What command do I have to put in to do the hand-off?

Thanks!

BTW - when I do a right click on an image I can do an “Open with Adobe Photoshop CS6…” so Windows knows it’s there and will use it just fine. otherwise.


(Morgan Hardwood) #2

http://rawpedia.rawtherapee.com/Preferences#Windows

Provide more info, tell us what you tried, whether you installed CS6 to its default location, what is its default location, etc.


(Adam) #3

Hello! Thanks for the reply. Photoshop is at: C:\Program Files (x86)\Adobe\Adobe Photoshop CS6

So I’ve tried both the built-in Adobe Photoshop Installation Directory (2nd ‘middle’) option, and also the command:
C:\Program Files (x86)\Adobe\Adobe Photoshop CS6\Photoshop.exe

Neither works at all. But Photoshop itself works fine.


#4

Is this happening due to your CS6 possibly being 32bit, as it installed in the “x86” Program Files folder, and needing extra flags to get it to emulate? For example, does it work when using CorFlags Photoshop.exe /32bit+ or CorFlags C:\Program Files (x86)\Adobe\Adobe Photoshop CS6\Photoshop.exe /32bit+
Just an idea because widows 64bit tries to segregate 32bit and 64bit stuff.


#5

I was looking into it, CorFlags works for .NET apps only and probably wouldn’t work here.


(Adam) #6

Thanks for the suggestions Hiram. Sadly no dice.


#7

The only other thing i could think of to try would be to reinstall cs6 but as a 64bit app. Some 32bit apps have no problem (for instance chrome and firefox exe’s), whereas some will not launch, perhaps due to vintage in the case of cs6.


(Adam) #8

Well it works otherwise fine, so can’t be too picky!


(Rick Scheibner) #9

I’ve had similar problems opening GIMP from RT 5.5 (and 5.4 before that). It’s Partha’s build, and I’ve tried all manners of pointing it to the correct directory with the correct file name.