Rawtherapee 5.3 and Lensfun [solved]


Did I misunderstand something or should Lensfun be working in RT 5.3? Yes, Profiled Lens Correction section looks different but I noticed two things:

  1. When loading an image the automatic profile does not pick up the lens LCP profile as it should. The “none” option is active.

  1. Even after choosing the “Manual correction parameters” option, it is not possible to choose a lens correction nothing can be chosen. The camera and lens dropdowns are not activated.

Am I doing something wrong? Has the Lensfun feature not been activated on purpose?

(Karlheinz Lehmann) #2

It should automatically fill in the fields camera and lens, not the LCP profile … So it does not detect your camera and lens. Does your camera is available in the filed camera? Did you have an older installation? Did you delete the options file?


It looks like a packaging error in openSUSE’s rawtherapee repository.
Rawtherapee uses the lensfun0 library which is only available up to version 0.3.1. KDE uses the lensfun1 library which is available in version 0.3.2. After downgrading the lensfun-data package to version 0.3.1 the camera showed up in the dropdown.

Now I will only have to change all my profiles again so rawtherapee uses the right combination of camera and lens is used by the dynamic profile rules.

(Philip B) #4

Having a similar issue…

lens does not auto-populate in the lens correction section. i have to chose it from the flyout menu.

Then when i do I get a little warning triangle next to it. Also, the vignette section is greyed out. But, the distortion correction is applied.

Very happy to have this integration. Most helpful, and nice to see RT developing so quickly. Leaps and bounds!!!



@PhilipB the warning is here because the crop factor of the lens correction data is greater than the crop factor of your camera.

In Lensfun DB
Crop factor of your camera: 1
Crop factor of your lens:1.528 (i.e.APS-C). It means that the data are based on a DX camera photo.

So be careful with result

(Philip B) #6

Ahhh,yes i see that. I thought tried to hover over the warning before but didn’t get a message about it. Trying again i saw the message. User error!

But should it auto populate?

Thanks guys…


If you provide to lensfun guys the required photos, they can generate calibration data. See the lensfun site if you want do that.

(Philip B) #8

Yes, i saw that! Ill definitely do that. I

also have an older 35mm PC lense with 11mm of perspective correction. Its a fantastic lens, but has weird distortion. Ill be submitting photos for different levels of shift for that one.

(Morgan Hardwood) #9

Where is your information from?

I’m using lensfun-0.3.2 and I seem to be using the lensfun version 1 library, and it works fine in RT:

Ping @agriggio

This is a different issue. It simply means that your camera-lens combination was not auto-detected, while @vato’s issue is that his lensfun library does not load.

(Alberto) #10

My understanding was that @vato was talking about the opensuse package for RT. In general, RT should work with any version of lensfun >= 0.2.8, possibly even earlier ones.