RawTherapee 5.3 Released


(Alberto) #141

@shreedhar do you have an antivirus, a firewall or some other malware detection software running?


(Morgan Hardwood) #142

@shreedhar to rule some things out, please create an empty folder, e.g. C:\empty and set that as your flat-field, dark-frame, hald-clut and startup folder.


(Alberto) #143

@shreedhar also, how long does RT take to start in “single editor” mode? I.e. when you give it a single RAW file as command-line argument?


(Shreedhar Inamdar) #144

Yes @agriggio the first time I ran your new file, the machine told me that this programme comes from an unknown source, do you really want to run. I clicked yes and also clicked, don’t ask me again. This did not happen to the standard RT 5.3 executable. So this is definitely different.


(Shreedhar Inamdar) #145

I never open RT from command line! I just click on the shortcut (that I created on the desktop) and it opens in SETM.


(Shreedhar Inamdar) #146

@Morgan_Hardwood I am trying out empty flat field directory now.


(Alberto) #147

well, would you try once, just for me? you won’t get hurt, I promise :wink:


(Shreedhar Inamdar) #148

Sure I will try!! I know, it sounds stupid to all of you but this command line business is too much !!!


(Shreedhar Inamdar) #149

OK @agriggio, I bravely went to command prompt and changed the directory to where your exe file was and typed rawtherapee-test and entered. It took again 25 seconds or so to open SETM. exactly the same as clicking on the shortcut.


(Shreedhar Inamdar) #150

@Morgan_Hardwood after changing the flat field and dark frame directories to C:/empty (from the default none), it still takes the same amount of time. 25 seconds.

Please note that it is still faster than before.


(Morgan Hardwood) #151

@shreedhar

  • Flat-field (Preferences > Image Processing > Directories)
  • Dark-frame (Preferences > Image Processing > Directories)
  • HaldCLUT (Preferences > Image Processing > Directories)
  • Startup folder (Preferences > File Browser > Image Directory as Startup, either set it to “Other” and point it to C:\empty, or set it to “Last visited directory” and go to C:\empty using the File Browser and then close RT - it will start there the next time you run RT)

(Shreedhar Inamdar) #152

Yes, @Morgan_Hardwood, I have set Haldcut, Flatfield, Darkframe and the startup directories as C:/empty. It still takes about 25 seconds. Preferences do show the empty folder as the directories for all of the above.


(Stefan Chirila) #153

@agriggio I did not compile it myself. I was using the version of 3.5 (the slower of the two) that comes in the debian testing repo, as well as a custom one i downloaded as deb file from <i’ll fill in when I get home tonight>


(Alberto) #154

@shreedhar I think I was unclear. what I meant is to start RT from the command line, but passing it a raw file as argument. something like this:

rawtherapee-test.exe "c:\my pictures\awesome.nef"

this activates a ‘simplified’ mode without the file browser. could you please try this and report the time? thanks again!


(Shreedhar Inamdar) #155

I did what you said and the time was down to about 17 seconds from the 25 seconds. I put the image file in the C: drive itself, no folders. Also, RT did open just the editor tab, without the file browser.


(Alberto) #156

thanks, this is helpful. I’ll dig deeper


#157

As silly as it sounds, on Win 10 one can try running a program with no internet connection. If “SmartScreen” feature is doing things in the background (checking everything unknown against MS databases), it will warn you, that it needs connection. At least for such issues, I would disable it completely. (The option to do this is getting more hidden with time.)

Any downloaded installer’s settings can reveal, that it is “from unknown source” and so “blocked”. “Unblocking” it manually prevents one additional warning.

AV programs, at least some, also can change their own settings silently when “upgraded”. I certainly didn’t alert anybody yesterday to get this message:

avast_alert

All this might not be relevant here, but trying to control all the Windows security software as much as possible can be sensible when developers are dealing with funny behaviour that only happens on some systems.


#158

I’ve tested the custom-file-chooser-button branch and didn’t find any issue. The startup time on my old dual core i3 2.9 GHz was 12 sec. and now it takes only 5 sec. :+1:


#159

So far, so good.
Even hours later, and several resume-from-sleep cycles, RT is still launching in less then 2 seconds! Even on dirs with dozens of large image files!

More remarkable: when I launch the original rawtherapee.exe it again takes about 50 seconds to start! :face_with_raised_eyebrow: and clicking on the ‘preferences’ button, takes at least another 20 seconds to appear.
But when I try the rawtherapee-test.exe; everything is quick & responsive immediately! Not even a restart is necessary. So there were definitely compile (?) bugs/errors in the original RT 5.3 for Windows release.


(Ingo Weyrich) #160

No, @agriggio just greatly worked around this bugs in gtk3. It may happen that you experience the 20/50 seconds delay now and then when you press one of the file chooser buttons :wink: