RawTherapee 5.4 AppImage font issue


(Stefan Chirila) #1

Hey guys, am running Debian testing and I downloaded the Rawtherapee 5.4 appimage from rawtherapee.com and it’s giving me squares for font …anyone any idea how to fix this?


(Carmelo Dr Raw) #2

I will have a look!


(Stefan Chirila) #3

I’m thinking maybe the appimage is trying to use a font I don’t have. So I painstakingly browsed to the preferences screen and tried to change the font but all look like that :frowning:


#4

Interesting. It is everything except the title. At least you know the app name and version :stuck_out_tongue_closed_eyes:.


(Stefan Chirila) #5

@heckflosse thanks for the correction :slight_smile:


(Stefan Chirila) #6

@afre i dont know whats going on. works fine on laptop, tho a bit sluggish :frowning:


(Carmelo Dr Raw) #7

Do you have the same system on both computers?


(Carmelo Dr Raw) #8

Also, could you post the terminal messages that you get when running the AppImage? If we are lucky there is some fontconfig error message that can help to clarify where is the problem…


(Morgan Hardwood) #9

Please post the output of

locale

(Carmelo Dr Raw) #10

@stefan.chirila @Morgan_Hardwood I think I found the issue… the problem is due to the fact that the AppImage bundles the fontconfig library, but tries to use the /etc/fonts/fonts.conf file from the system. In some cases, the fonts.conf is too new and not compatible with the bundled library.

I have prepared new packages that do not bundle the fontconfig library, so that the system fonts are always used. Could you please check this one for example?

If this works, I will apply the same patch to all other AppImages I am providing.

EDIT: there is still a small issue with svg icons, that I am trying to solve right now…


(Morgan Hardwood) #11

Once the fix is confirmed, I will update the 5.4 AppImage on our website.


(Stefan Chirila) #12

@Carmelo_DrRaw @Morgan_Hardwood OOOH this is sooo cool :slight_smile: thank you so much for the effort. I am currently not at home but I will try and let you know within the next 8-10 hours.

@Carmelo_DrRaw I am using Debian, updated to testing on both my desktop and laptop.

I wonder if the SVG icon thing is what makes it slightly slow. Honestly, I am currently running a 5.0 Gtk2 version which is the last version I could find that doesn’t run slowly (as in choppy implementation of either image modifications, or even slider movement), so I am really looking forward to trying a newer version if one is available that runs acceptably.

Once this gets sorted out I’ll look into an appimage for the new Gimp which I am super excited for and hasn’t yet made its way into the debian repos.


(Carmelo Dr Raw) #13

Hold on for a while still, I am running some tests of different fontconfig configurations and various linux distributions (debian stable & tests, ubuntu 14.04 & 16.04 & 18.04, fedora 26 & 27 - Docker containers are fantastic for this kind of tests!) to see which one is compatible with all system environments.

I’ll drop a message here as soon as I’m happy with the result.

For GIMP appimages see here: https://github.com/aferrero2707/gimp-appimage/releases/tag/continuous (you might encounter the same fonts issue in the GIMP case).


(Stefan Chirila) #14

It’ll be another 6h before I get home; so you have some time :slight_smile:
Thanks also for all the effort. It’s just awesome that these appimages exist until individual distros come up with good packages of their own. Debian’s deb versions are all sluggish too :stuck_out_tongue: but one day …one day :slight_smile:


(Stefan Chirila) #15

The one you linked to here seems to work. The font works. It’s still a bit on the slow side when loading a raw file and when applying slider actions. Even the mouse feels like it has less frames/sec or maybe i’m losing it… i dunno. But the font works :slight_smile:

@Morgan_Hardwood font issue is confirmed solved :smiley:


(Stefan Chirila) #16

@Carmelo_DrRaw no font issue in the gimp appimage


(Stefan Chirila) #17

@Carmelo_DrRaw I think what I call sluggish behaviour might be due to it being an AppImage. I installed Gimp 2.10 via flatpak and it runs way snappier than the appImage. Though it shouldn’t make a huge difference on an 8core 4Ghz with 32GB RAM :frowning: Or?


(Mica) #18

The AppImage packages almost all the necessary libraries. But not all of them. There is a slim possibility it is a library conflict.

The start up of the AppImage is not super fast, but the speed should be good once the application is running.


(Stefan Chirila) #19

@paperdigits Guess it’ll do until I get a native deb :slight_smile:


(Carmelo Dr Raw) #20

The sluggish behaviour of the AppImage is not normal… could you please try the following:

  • install bsdtar
  • create a folder where to extract the AppImage contents, something like
    mkdir RawTherapee.AppDir
  • go into this folder and extract the AppImage contents:
    cd RawTherapee.AppDir
    bsdtar xfp FULL_NAME_OF_THE_RT_APPIMAGE
  • the run RT like this:
    ./AppRun

Is this faster? If yes, the slowness might be due to some repeated access to some files in the AppImage bundle, which AFAIK is a compresse archive that gets deflated on-the-fly.