RawTherapee nightly builds

I’ve been in the habit of downloading a new RT appimage every few days, especially as the film negative tool is progressing so quickly. Right now, however, the latest appimage that I find is still from January 21, 2021. Am I on the right download link? https://github.com/Beep6581/RawTherapee/releases/tag/nightly

4 Likes

The appimage is still stuck on Jan. 21, now 5 weeks behind the Windows version.

4 Likes

Has production of the nightly AppImage files been officially abandoned?

I’m sure we’ve just hit some snag, hang on.

I’ve been using nightly builds for some time. Fact that they are not available anymore forced me to build it by myself. What a surprise, the locally built RawTherapee is noticeably faster. Give it a try, simply download the dependencies and run the script, everything you need to know is described here: https://rawpedia.rawtherapee.com/Linux .

2 Likes

That’s not a surprise. RawTherapee native builds (compiled for the machine you are using) should be faster than generic builds because they can make better usage of your machine (cpu, knowing about cache size, preferred simd size and so on)

Sometimes, the automation fails. I pinged @Carmelo_DrRaw a handful of times but he has been unavailable. Hope he is okay during the pandemic…

Of course, and it is easy to do on Linux too. I find it awkward on Windows (plus my laziness :stuck_out_tongue:), so I rely on the nightlies.

I hope this too…

Where is the repo that runs the CI? Surely someone else can fix it.

I don’t see where the builds are failing…

Dear all,

let me apologize for the silence and lack of support for the nightly builds, but recent times have been quite tough, and my daytime job and private life have absorbed all my spare time. In any case, we are all doing fine and for the moment we have gone through the pandemic with no issues… let’s hope that things will keep going this way! I also hope the best for you all!

Hopefully in the coming weeks things will calm down a bit, and I will finally manage to catch up all what I have put aside. But likely not before the end of March…

Take care!

16 Likes

Stay well and I hope things improve for you shortly. We miss the nightly builds, but that can wait. It’s more important for you to take care of your health and your family.

3 Likes

I followed the instructions given in the link and was able to successfully build the latest dev version on my Lint Mint 20.1 desktop PC. The build runs fine, except I’ve noticed that one of the lenses that I use with my Canon 7D Mk2 doesn’t appear in the list of lenses.

The lens in question is the Tamron 18-400mm f/3.5-6.3 Di II VC HLD (B028).

When I checked the last AppImage nightly build it does include that lens, plus a whole lot more Tamron lenses which exceeds the height of my PCs screen. In contrast, the dev build compiled from the latest source code has less than half that number.

Is there a way to get the data for all the lenses that are in the AppImage build incorporated in the build from source code?

Edit:
I have solved the problem by updating the lensfun data on my PC.
First I had to use Synaptic Package Manager to install the liblensfun-bin package.
Then I ran: sudo lensfun-update-data
When I ran my local build of RawTherapee dev it then found the Tamron 18-400mm lens, plus all the extra Tamron lenses that are available in the AppImage build. :smiley:

1 Like

I have downloaded the latest version for windows in zip downloaded from:

RawTherapee_dev_5.8-2813-gbb08b6bed_20210309_win64.zip

And when I access a directory that has previous pp3 the RT closes.

It happens to someone else?
Thanks.

Edit/ The previous one I had worked fine:
RawTherapee_dev_5.8-2810-gdda9b8ed6_20210307_win64.zip
Edit2/ .EXE doesn’t work either

@heckflosse, where would I find the native dev builds best suited for coffee lake cpu?

Here

For Windows and MacOs there are also links…

@arturoisilvia There was an upstream problem for the Windows builds. This is why the most recent nightly builds fails to run. Please try again tomorrow (or the day after) and please report back if the problem persists.

Okay, thanks.

Windows nightly builds seem to be stuck as well