RawTherapee nightly builds

I hoping someone may help.
Goal is to have RT dev version on my Ubuntu Mate 20.04 box.
I did the following but did not get an executable.

I think I followed the instructions properly -> Link <-
-ran the dependency script for Ubuntu
-then proceeded to Compilation - the automatic way script
The script did not terminate with “To run rawtherapee type: …”
It may not have built properly, could anyone help, point me the right direction?

Thanks,
Rick

AboutThisBuild.txt
Version: 5.8-2847-g53bb6e41b
Branch: dev
Commit: 53bb6e41b
Commit date: 2021-04-22
Compiler: cc 9.3.0
Processor: x86_64
System: Linux
Bit depth: 64 bits
Gtkmm: V3.24.2
Lensfun: V0.3.2.0
Build type: release
Build flags: -std=c++11 -march=native -Werror=unused-label -Werror=delete-incomplete -fno-math-errno -Wno-attributes -Wall -Wuninitialized -Wcast-qual -Wno-deprecated-declarations -Wno-unused-result -Wunused-macros -fopenmp -Werror=unknown-pragmas -O3 -DNDEBUG -ftree-vectorize
Link flags: -march=native
OpenMP support: ON
MMAP support: ON
Build OS: Linux 5.4.0-72-generic x86_64
Build date: Fri, 23 Apr 2021 01:18:10 +0000 UTC
Build epoch: 1619140690
Build UUID: 05c56139-1e21-41e9-87b0-af7da84eb1b9

@r8n hi and welcome!

Hard to tell if it finished successfully, please post the output from the terminal.

Hi Mica,

Attached is output from the terminal (hope I got this right)

Rawtherapee-install.txt (4.0 KB)

Something really weird is going on. Are you even executing the build script? If the contents of the script show up in your terminal, things are not working.

My guess @r8n is running the script instead of the program …

There’s also this bit:

185 sudo gedit/ etc/ default/ grub
186 wget https://raw.githubusercontent.com/Beep6581/RawTherapee/dev/tools/build-rawtherapee -O build-rawtherapee

Both lines shouldn’t be there.
I don’t know what the sudo part is supposed to do, but it isn’t part of the build process.
The wget … command is already done previously: Line 182 and 183 show that the script is fetched (182) and the correct executable permissions are set (183). And then at line 186 it is fetched again, overwriting the previous instance, but no permissions are set this time.

You also mention this:

Which script would that be?

I (double) checked but there is no dependency script. There’s a list of dependencies and there’s a command to install some basics (Which might or might not be enough to fulfil the current dependencies).

Assuming for the moment that your dependencies are all set up, you should just be able to open a terminal (ctrl-alt-T on Ubuntu if I’m not mistaken) and copy and paste the following lines:

cd ~
wget https://raw.githubusercontent.com/Beep6581/RawTherapee/dev/tools/build-rawtherapee -O build-rawtherapee
chmod +x build-rawtherapee
./build-rawtherapee | tee rt_build.log

I added the | tee rt_build.log part, which would give you a text file that has some info if that last command doesn’t work (might be handy for checking the dependencies).

EDIT: Typo/added some emphasis.

1 Like

Thanks for the feedback and suggestions.
This is the output from script in Jacques response
I had run the commands from “install some basics” which I mistakenly call a script i suppose.
Looks like I am still missing something.
Thanks for every ones help.

:~ cd ~ :~ wget https://raw.githubusercontent.com/Beep6581/RawTherapee/dev/tools/build-rawtherapee -O build-rawtherapee
–2021-04-28 18:37:55-- https://raw.githubusercontent.com/Beep6581/RawTherapee/dev/tools/build-rawtherapee
Resolving raw.githubusercontent.com (raw.githubusercontent.com)… 185.199.108.133, 185.199.109.133, 185.199.110.133, …
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|185.199.108.133|:443… connected.
HTTP request sent, awaiting response… 200 OK
Length: 4373 (4.3K) [text/plain]
Saving to: ‘build-rawtherapee’

build-rawtherapee 100%[===================>] 4.27K --.-KB/s in 0.002s

2021-04-28 18:37:55 (2.24 MB/s) - ‘build-rawtherapee’ saved [4373/4373]

:~ chmod +x build-rawtherapee :~ ./build-rawtherapee | tee rt_build.log

Program name: rawtherapee
Build type: release
Build without updating: false

No updates, nothing to do.
:~$

It looks like everything has gone as expected and you should be good to go.

The message you see at the end, this bit:

Program name: rawtherapee
Build type: release
Build without updating: false

No updates, nothing to do.

Is shown when the script determines that rawtherapee is already installed and up-to-date. I’m not 100% sure if this also shows if a partial install was done (as in: something went wrong during the install part).

Isn’t rawtherapee accessible from the ~/programs/rawtherapee/ directory? There should be, among other files, two executables rawtherapee and rawtherapee-cli (the latter isn’t important at the moment).

If those aren’t there or you cannot start the rawtherapee one can you post the output of the following command (done from a terminal (ctrl-alt-T):

ls -l ~/programs/*

You may still have 2 more options to try:

  • run ./build-rawtherapee -b (this forces to build RT without updating the source-code)
  • delete the sourcecode-rawtherapee folder, wherever it is, and run again the script (./build-rawtherapee, without the -b option)

But first you have to make sure all dependencies are installed…

This is the one I run in Linux Terminal inside Parallels - it all seems to work fine every time, thanks to you giving me the instruction months ago matey :+1:

1 Like

Well, to be fair you didn’t use the «standard» script, but a custom one edited by myself. It’s basically the same, but you can choose several things explained inside the script text.

Here it is, if it can be of any help to somebody:
build-rawtherapee.zip (2.2 KB)

However, this script is not supported by devs, so if you face any problem, I guess it would be me who should answer questions, and more often than not I won’t be of any help. So use it at your own risk.

1 Like

Thanks guys, I have it running

Yes they are both in the directory, clicking on them I get
“There is no application installed for shared library files. Do you want to search for an application to open this file?”

Here is: ls -l ~/programs/*
ls-result.txt (2.4 KB)

I then ran

The last lines where of the result was:
“To run rawtherapee type:
/home/alpha/programs/rawtherapee/rawtherapee”

Typing this into the terminal starts Rawtherapee in all its glory!

I have yet to try the following. (To confirm the sourcecode folder would be named “code-rawtherapee”?)

Thankyou for everyones help, greatly appreciated.

Congrats! :slight_smile:

Whenever you want to update the program, just run again: ./build-rawtherapee

If that fails for some reason, try: ./build-rawtherapee -b

And only if that one also fails, delete the «code-rawtherapee» folder (you’re right, sorry), and run: ./build-rawtherapee (without the -b option)

I just fixed the nightly AppImage builds.

10 Likes

Much appreciated, thanks Morgan!

not seeing any windows dev builds on the nightly releases, am i doing something wrong or are they glitched?

You can try if one of @gaaned92’s builds works on you computer:
https://keybase.pub/gaaned92/RTW64NightlyBuilds/
I will wait until the automatic build process works again

It is only a little behind (RawTherapee_dev_5.8-2852 vs RawTherapee_dev_5.8-2853).

The automated Windows build process is still broken, working on it.

2 Likes

Didn’t know about those, one worked, thanks!