RawTherapee UI language on Windows

rawtherapee

#1

RawTherapee doesn’t seem to detect the system language correctly on Windows. It’s in English, and one has to select the language manually and then re-start the programme.


#2

Do you mean the installer or after installation? And does this problem persist after your first restart?


#3

In Rawtherapee:

  • go to preferences/general/langage
  • tick use system langage or use whatever langage you want
  • restart rawtherapee

By default, it uses “system langage” when there is no option file.

Edit: what are the versions of Windows and Rawtherapee ?


#4

@afre @gaaned92: The problem is that after the installation of RT 5.5 the default is set to the system language, which is German in this particular case. However the UI is actually in English, so I need to uncheck the system language and choose German manually from the drop-down menu. In other words, RT 5.5. doesn’t detect the system language on Windows 10 (or 7).


#5

@christoph_s
Sorry I did’nt understood the problem.
Here I cannot reproduce:

  • system W10, system langage french, RT5.5 official
  • I delete the option file
  • I restart RT. The default is set to `system langage
  • the UI is in french as it should

Note: when installing a new version, the config folder is not reset so you keep your existing options.


#6

I can confirm this bug. I’m using Win 10 Home German and RT uses English when System language is checked.


(Ingo Weyrich) #7

Bug confirmed. Though, when I start from msys2 console it works fine. Looking…


(Ingo Weyrich) #8

I pushed a fix