[Resolved] Two point tracking in Transform mode ignores transform Center


#1

Hi!

I’m trying to do a 2-point tracking but It doesn’t work as I expected. Yo can see the behavior in the video below.

I have two tracking markers (cannot show the image). When I apply the motion type to Match-Move and set the Transform Type to CornerPin it works fine. However, I need the Transform Type to be Transform, but when I set it to Transform, you can see the transformation gizmo moving away. It should stay between the two markers as (as I show later) one point tracking stays in the same place where the tracking marker is.

The question is, how can I have a working transformation match-move with only two markers?

EDIT: I’m using Natron 2.3.12 in Windows 64-bit


(http://4232.cf) #2

2018-06-11-184559_278x172_scrot

unlink tracker of source image


#3

Thanks, but that’s not the problem. Actually, I have the same problem if I export the Match-Move into a Transform node.


(Chris Tempel) #4

Did you try creating a transform node from your tracker node?


#5

Yes, I did :frowning: It works for you?

The only thing “odd” in my workflow is that I tracked backwards and set the Reference frame as the last one. Anyway that shouldn’t be problematic, and the same problem occurs if I set the first frame a Reference frame.


#6

Ok, I tested with a new scene. The result bad too. In this case, the result is not as awful as the original because the camera does not move forward. Anyway, is unusable as a match-move.


(Frédéric Devernay) #7

Why not use the CornerPin mode if it works?


#8

Because I only wanted the rotation and scale of the match move :confused:

Anyway, the documentation says about Transform:

At least 1 track is required to compute the translation and 2 for scale and rotation.

So I thought it may be broken or I was making it wrong in any way.


(Frédéric Devernay) #9

Yes, it’s probably broken, and it is easy to find where this happens in the code, but I have no time to do it.
Post an issue on github with all the useful information you posted here and a zipped NTP (we don’t need the source video as long as the tracks are here).
If you want it solved, you can put a bounty on it, and maybe someone will solve it and take the bounty.


#10

Great, thanks! I’ll do it :slight_smile:


(Frédéric Devernay) #11

Setting the center to 0,0 in the transform parameters fixes it for me. Can you please check that it works for you too?
This is definitely a bug, of course.
I posted an issue for you: https://github.com/NatronGitHub/Natron/issues/289

trackertransformbug.ntp.zip (88.2 KB)
image


(Frédéric Devernay) #12

This is now fixed. Please try the next snapshot and report if it’s OK or not.


(Frédéric Devernay) #13

and BTW, you will get a better estimate for the transform if you use more than two points.