RT 5.4 dies in browse & delete


(Syv) #1

RT 5.4: the appimage on Manjaro

  1. In the file browser: 268 images
  2. Select 4 images
  3. Right click > File operations > delete (not move to trash)
  4. Do you want to delete yes/no
  5. yes

and RT freezes. Nothing after 3 (actual) minutes. I had to click on the close window to cancel the delete and close RT.

Did it a second time and same thing. This time, I waited 7 minutes, closed again.

The file permissions are:
$ ls -alF john*.raf
-rw-rw-rw- 1 froggy froggy 50565120 Mar 28 19:00 john-indian-29147-20180328-5012.raf
-rw-rw-rw- 1 froggy froggy 50552320 Mar 28 19:03 john-indian-29147-20180328-5013.raf
-rw-rw-rw- 1 froggy froggy 50546688 Mar 28 19:03 john-indian-29147-20180328-5014.raf
-rw-rw-rw- 1 froggy froggy 50549760 Mar 28 19:03 john-indian-29147-20180328-5015.raf
-rw-rw-rw- 1 froggy froggy 50534912 Mar 28 19:03 john-indian-29147-20180328-5016.raf

and I’m the owner.

Bug or I’m doing something wrong?

Thanks

Syv


(Ingo Weyrich) #2

Bug, but nothing we can do about atm.


(Flössie) #3

But we’re not talking about Windows here… :confused: Tried to but could not reproduce with latest dev on Debian 9 here.


(Ingo Weyrich) #4

Oh, missed that :frowning:


(Morgan Hardwood) #5

@foto I’m not sure about the diagnosis, because the linked bug applies to window focus in Microsoft Windows, while you’re in Linux.

I tried reproducing what you described using my own build in Sabayon and could not reproduce, it worked fine. I can’t test using the AppImage as it doesn’t run in Sabayon.

@foto two things:

  1. Could you try to reproduce using 5.4 from your package manager, not the AppImage?
  2. Could you show a video recording of the problem?
  3. Could you debug it? The steps are as follows, though I have no idea whether they apply to an AppImage:
    1. Run RT.
    2. When it hangs, in a terminal write: pidof rawtherapee, that should return a number. If it did not return a number then end here because I don’t know how to handle an AppImage, maybe @Carmelo_DrRaw can help.
    3. If it did return a number, then write: gdb -p "$(pidof rawtherapee)"
    4. Once GDB loads, type “c” to continue (and hit enter).
    5. Alt-tab to RT, if RT is still frozen then alt-tab back to GDB and hit ctrl+c.
    6. Type bt full, hopefully you get a backtrace which shows where RT is stuck. Paste it here.

(Carmelo Dr Raw) #6

I have just tried with the latest AppImage (https://github.com/aferrero2707/rt-appimage/releases/download/continuous/RawTherapee-5.4-20180328_1621.glibc2.17-x86_64.AppImage) on Ubuntu 17.04, deleting 4 files simultaneously, and I could not see any freeze.


(Syv) #7

Run RT. When it hangs, in a terminal write: pidof rawtherapee, that should return a number. If it did not return a number then end here because I don’t know how to handle an AppImage, maybe @Carmelo_DrRaw can help.

I created a new directory and copies a bunch of files and then started to delete them in bunch of 4s. It works :frowning: BTW, pidof rawtherapee works with the appimage.

As I said on my first post, it looks like either it’s an elusive bug or I was doing something wrong. The problem is what could I have been doing wrong? The file permissions were OK and I was the owner of the files (in anyway RT should have given me some kind of error message…)

Thanks

Syv


(Carmelo Dr Raw) #8

@foto @Morgan_Hardwood @heckflosse @floessie

Not completely related to this specific problem, but trying to reproduce this on MacOS I noticed the following terminal message:

Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.

This probably means that the code is not calling

set_transient_for()

on the dialog (see here), and therefore the window manager might decide to open the dialog below the main window.


(Flössie) #9

Good point, Andrea. Same message on Linux.


(Morgan Hardwood) #10

I don’t think you did anything wrong, it’s probably a bug. The other day I was changing folders in rapid succession before the thumbnails finished generating, and I managed to deadlock RT. Found nothing with GDB though.


(Morgan Hardwood) #11

I tried fixing that 4 days ago when examining the tooltip issue, but failed.


(Carmelo Dr Raw) #12

What do you mean by “failed”? It did not compile, or you didn’t find a proper solution?


(Morgan Hardwood) #13

@Carmelo_DrRaw the former, but that’s just a symptom of me not being a C++ coder, not an indication of the difficulty of the problem.


(Carmelo Dr Raw) #14

I can try to have a look, but not before a couple of days.


(Morgan Hardwood) #15

That would be great!


(Ingo Weyrich) #16