RT 5.8 scroll bar encroachment

I recently got a new laptop and installed Mint 20 linux as a dual boot system. After installing RT 5.8, I found that the vertical scroll bar is too wide and I cannot use the + and “revert to default” controls in the editing tabs. The scroll bar is hidden, even though “hide vertical scroll bar” is unchecked in preferences. But as soon as the cursor enters the right pane area, the scroll bar starts “unhiding”, and as soon as I try to hover over a + button, the scroll bar covers it.

This was installed via the Mint software manager. I uninstalled it, and installed the image directly from the RT download page. Same issue. Uninstalled that, then installed the flathub version that was listed in the software manager. That one works, the scrollbar is thin as it should be and doesn’t hide any controls. “Unhide the scroll bar” still does not work, it’s always hidden until you mouse over, but at least it’s usable now.

Please provide screenshots. What is your screen resolution? It is curious that the different versions behave differently. Could you please check if you can also reproduce this issue? https://github.com/Beep6581/RawTherapee/issues/6048

This setting hides the scroll bar when it’s not necessary, but it will always appear when it’s needed. Unsetting the “hide vertical scroll bar” should always display the scroll bar even if it not necessary.

I have just tested this on a laptop running Mint 20.1 MATE, using RT 5.8 installed from Software Manager.

When I first ran RT, I was seeing a similar problem - the plus and reset buttons were obscured by the vertical scrollbar.

However, when I dragged the border between the right panel and the central image display section, the width of the right panel increased and the buttons moved clear from the scrollbar and could be clicked on without any problems. After closing and re-starting RT, the new width of the right panel was remembered, so the problem didn’t reoccur.

The screen resolution is 1600 x 900. I changed to 1920 x 1080 and 1368 x 768, no effect on the scrollbar issue. The OS is Mint 20.1 Cinnamon. I could not reproduce the issue 6048, although when the cursor enters the pane, the scrollbar emerges at ~50% opacity for about a second, then disappears again. Screenshots are: “RT 5.8 cursor move into panel”, of which I had decsribed in the previous sentence. “RT 5.8 flathub” which produces the normal thickness scrollbar, but you see “hide vertical scrollbar” is unchecked and it is still hidden. “RT 5.8 flathub scrollbar” shows the normal-sized scrollbar. “RT 5.8 scrollbar issue” shows the abnormally wide scrollbar covering up the controls. I had the cursor on the scrollbar during this screenshot, as it cannot be unhidden. You’ll notice the wide scrollbar on the filmstrip also, and its wide in the file browser too.

I tried this, didn’t work.

This seems like a gtk issue, either with gtk itself or the mint gtk theme, as flatpak ships it’s own version of gtk, which is why it is different

This is what I see in Linux Mint 20.1 Cinnamon, using RTdev commit 227ae487d:

Left to right:

  • «Hide vertical scrollbar» unchecked
  • «Hide vertical scrollbar» turned on: the panel gets horizontally compressed to make room for the scrollbar (but «it’s not there»)
  • whenever the mouse pointer is over the panel, a thin scrollbar appears, and disappears when the mouse is still (no movement), reappearing on each movement
  • when the mouse pointer is over the scrollbar: it gets wider so it’s easier to click and drag it

So in my opinion is not just a matter of some gtk version. I would bet is has something to do with the OS configuration, as in the OS theme configuration. Although I think we both use the same theme: Mint-Y.

Ahh, yes, Thank You, that is the source of the problem. Yes, also using Mint-Y, and toggled on/off the setting in “Scrollbar Behavior”. If “use overlay scroll bars” is ON, the scrollbar in RT cannot be unhidden. And if “override the current theme’s scrollbar width” is ON, that was the source of the unusually wide scrollbar. I had both ON, and turned them off, now RT is fine.

1 Like