RT & HD laptops screens


(Syv) #1

RT 5.3 and Dell inspiron 15 - 5000 serie with a 15.6" HD screen.

RT doesn’t fit on the screen. The end of the right panel (the numbers and the reset “dingy”) and the bottom with the status bar get cut off. Maximizing doesn’t help.

With the preferences, I don’t even see the About/OK/Cancel buttons.

Is there some setting (or config file) that I can control the width of the panels and the size of the screens?

Thanks

Syv


(Morgan Hardwood) #2

No screenshot = imaginary help.

Change your desktop scaling to 100% or something that fits your screen, and make the font smaller.


(Syv) #3

Tried that (set the scaling from 96dpi to 72dpi). Didn’t work.

Here’s a screen capture: https://i.imgur.com/Ewpgk65l.png

It cuts the end of the right panel.

Thanks

Syv


(Mica) #4

It cuts off the panel even if you resize it?


(Morgan Hardwood) #5

@foto show a screenshot of the whole screen, don’t crop the screenshot. I don’t see any problem in that little screenshot. RT fits just fine on a “HD screen”. What exactly do you mean by “HD screen”, what resolution is it? “HD” is vague.


(Syv) #6

I think I have solved the problem (more testing needed). It looks like it has to do with the xfce panels (top & bottom) and setting them both to “intelligent”, now I can see my screen up to edge.

BTW paperdigits mentioned resizing the panels (in RT?) That was my original question: how to I resize the panel in RT because the right one was being cut-off?

How to resize the RT panels?

Thanks

Syv


(Mica) #7

Just grab the side of the panel with the mouse, click and drag.


#8

When I add a detail window, the default behaviour is to place it on the right hand side. On a small screen, the right panel is covering the right edge. If I drag it farther to the right, it becomes inaccessible unless I hide a panel. When hiding a panel, the position of the detail windows relative to the preview changes, so I have to move them back and forth. This means that I would have to move the detail windows every time I toggle a panel.

It would be great if
1. the detail windows kept their position relative to the preview
2. and they couldn’t be hidden by a panel.


(Brass band at a park.)

Speaking of panel toggling, I cannot do that for the right panel, since the bottom toolbar is cut-off (as @foto put it). I can only toggle it when I give the toolbar more room by hiding the left panel.


#9

Open preferences and set the vertical toolbar on the left to the top. This will save you couple of pixel horizontal.


#10

I updated to 5.4-641-gc45c638ed. There are two new problems.

1. Preferences’ About-OK-Cancel row is below the screen. I have to tab my way down. (No vertical scroll bar.)
2. Queue is displayed horizontally when there are items in it.

image

PS.
3.
Some icons overlap.

image


(Morgan Hardwood) #11

http://rawpedia.rawtherapee.com/How_to_write_useful_bug_reports

Please file bug reports in the correct place with the correct info.


(Morgan Hardwood) #12

#13

I will try. I just made a GitHub account; put it off so long that someone took “afre”. :blush:


#14

If you change the setting you must restart RT.


#15

Try the TooWaBlue theme.


#16

I took another look. It appears that

1. the padding is quite extreme
2. RT (or GTK3) ignores the space occupied by the Windows task bar and is obscured by it.

Edit: I cross-posted on GitHub.

Without the task bar. The tops of the 3 buttons are barely visible at the bottom.

Without the task bar. This time with the TooWaBlue theme.


#17

Change the font size to 9. This will shrink the TooWaBlue theme.
You also didn’t resize the window to it’s smallest possible size. Compare the height of your and mine screenshots.


(Morgan Hardwood) #19

Please don’t cross-post.


#20

Okay, I am a little confused because I am replying to @TooWaBoo here but find it relevant on GitHub as well. This is new to me. What should I do?

PS From now on, I will reply here: https://github.com/Beep6581/RawTherapee/issues/3994.