showFoto - Segmentation fault

Hello,

I installed digiKam on my Linux machine and I want to use showFoto to edit images. When I launch showFoto it has tiny UI. Same was with digiKam, I just had to enable High DPI support in settings. On showFoto I can’t access settings. When I click Settings -> Configure Showfoto the app crashes.

I ran showfoto in Konsole to see more details on what happens and I get this:

[adomas@genesis ~]$ showfoto
QCommandLineParser: already having an option named "h"
QCommandLineParser: already having an option named "help-all"
QCommandLineParser: already having an option named "v"
HEVC encoder max bit depth: 8
HEVC encoder max bits depth: 8
Segmentation fault (core dumped)
[adomas@genesis ~]$

As I understand this indicates a bug, yes? If so, to make a proper bug report I would need to collect more info on this. How could I do it?

Yes, that’s a bug. Check out “Dealing with Crashes in digiKam” on https://www.digikam.org/contribute/. And generally the most basic info you always need to give when asking for help on software is build (digiKam version, how did you install it) and system (which OS, …) info.

I follow the instructions how to debug crashes in digiKam and showFoto, but it seems my package is without debug symbols, so it can’t generate anything useful:

[adomas@genesis ~]$ gdb showfoto
GNU gdb (GDB) 10.1
Copyright (C) 2020 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<https://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.

For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from showfoto...
(No debugging symbols found in showfoto)
(gdb) catch throw
Catchpoint 1 (throw)
(gdb) run
Starting program: /usr/bin/showfoto
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[New Thread 0x7fffdd63b640 (LWP 10787)]
[New Thread 0x7fffd5959640 (LWP 10788)]
QCommandLineParser: already having an option named "h"
QCommandLineParser: already having an option named "help-all"
QCommandLineParser: already having an option named "v"
[New Thread 0x7fffcffff640 (LWP 10789)]
[New Thread 0x7fffcf7fe640 (LWP 10790)]
[New Thread 0x7fffceffd640 (LWP 10791)]
[New Thread 0x7fffce7fc640 (LWP 10792)]
[New Thread 0x7fffcdc87640 (LWP 10794)]
[New Thread 0x7fffb78a1640 (LWP 10795)]
[New Thread 0x7fffb70a0640 (LWP 10796)]
[New Thread 0x7fffb689f640 (LWP 10797)]
[New Thread 0x7fffb609e640 (LWP 10798)]
[New Thread 0x7fffb589d640 (LWP 10799)]
[New Thread 0x7fffb509c640 (LWP 10800)]
[New Thread 0x7fff9d967640 (LWP 10812)]
HEVC encoder max bit depth: 8
HEVC encoder max bits depth: 8

Thread 1 "showfoto" received signal SIGSEGV, Segmentation fault.
0x000055555558807d in ?? ()
(gdb)

I’m running Arch Linux x86_64 Linux 5.9.11-arch2-1
KDE 5.76.0 / Plasma 5.20.4
with NVIDIA GPU using 455.45.01 driver

How can I know if I need to report this to Arch bugs or as digiKam suite bug for KDE bugtracker?

That could/should probably link to https://download.kde.org/stable/digikam/7.1.0/, where there are debug builds including symbols.

When you use a distro package, report to their bugtracker first. They will tell you if you need to report it upstream (at digiKam itself) or not (or file the bug themselves).

1 Like

The crash in showFoto when calling the settings has now been fixed in digiKam-7.2.0-Beta2.

1 Like