Siril crashes on opening GTK error


After a long time of running with no problems, Siril now does not open, and gives a GTK error. Screenshot is enclosed.

  1. Win10, x64, latest update. This is not the issue as Siril runs okay on my tablet with the same windows version.
  2. Intel and NVidia graphics. Same crash on both
  3. tried complete uninstall and reinstall. No luck.
  4. I waited for a few minutes in the hope that the warnings would clear up. No luck.


I have no idea on what is going on here.
If a gtk expert has a clue.

Never seen this error before.

Is gtk bundled with Siril or installed separately?

If you use our package, it is bundled with.

Okay then am at a loss.

Basically when I open Siril, 2 windows open as usual. The console gives the error as in the screenshot.

The GUI window does not open. But it can be seen from the taskbar. If I select it from there and try to open it, it seems like it is in front of the console but with high transparency.

So I tried something else.
As soon as the console opens, I minimise it. Then the main GUI window opens briefly. Then the GUI window vanishes and the console comes up with the error message.

Okay got it working by running as admin.

I dont think that was the case earlier.