Siril will not launch

Hi, I’ve only just started using Siril yesterday & ran into the starnet++ bug on windows. I’ve used the .bat file found in the patch notes on the Siril website, downloaded and ran it. The cmd window pops up and closes again but Siril doesn’t launch. Now I can’t even launch Siril through the application itself. I have tried redownloading Siril but I’m still unable to launch the application. Prior to the .bat file it would run fine.
Any help would be greatly appreciated!

Update - Can launch Siril 1.0.6 but not Siril 1.2.0-beta1 or Siril 1.2.0-beta2

Hello, if you were able to launch it but not anymore, it’s probably because an antivirus decided you should not use Siril. Try disabling it or allowing to be run, to test if you can start it again. The bat file was for the beta1 version and should not be used otherwise than to fix the starnet issue of beta1.

Still unable to launch the latest version of Siril. I have given the files permission through my anti virus etc. It simply will not launch. The beta 1 used to work fine until I ran the .bat file 4 days ago. As stated above ive tried uninstalling etc. Any ideas?


other than try rebooting, I have no other idea.
Maybe use the bat file and add a line to prevent the window from closing after it fails:

“C:\Program Files\Siril\bin\siril.exe” >log.txt




I have the same problem! Siril worked for a few weeks then a few days ago, suddenly, it just refuses to launch. I also can download the 1.0.6 version via the Microsoft store but I can’t launch the 1.20 beta 1 and 2 versions.

Please let me know if you found a solution.


Download this file:

Replace the word nul by log.txt inside the file. Then put it on your desktop and try to launch siril by double clicking on the bat file.

You will have a log.txt file on your desktop. Send it to me.

Hi mate, heres the txt file.

log.txt (265 Bytes)

Ok. That does not give any information. Except that sirop is starting because there are some logs.
Maybe try to remove the config.ini file before trying to relaunch the app

It has just returned the text same txt file. No extra information

So try to remove config.ini in the folder siril which is located in %LOCALAPPDATA% on Windows

Ahh Ha!

I had the appdata folder hidden! Found it and removed the config.ini. Siril now opens! Thank you so much.

In case it happens again, could you pls send over the faulty ini file before removing it? So that we can try to figure out what’s going on?

1 Like

@Cantina please provide you config file before removing it.

The window of the bat file opens and immediately closes.

I also just got it fixed. Thanks, everyone.
By providing my config file, do you mean sending it? In mine, it was all blank with no text.