[solved] darktable crash on import

Hi, on Mac 10.12.6, just downloaded from github. Before downloading this version, I had uninstalled the old version (3.6), and rearranged my folder structure and image filenames. Thus all my film rolls were crossed out in collections. I ran darktable-generate-cache, removed each film roll one by one until there were none left, then tried to import a new folder. Only a few images imported before darktable crashed. The program may also crash if I click on the (partially) imported collection and change the ‘view’ from 5 star to all. If that doesn’t make it crash, double clicking on the collection will.

Here is the .txt after running darktable -d all
darktable crash on import -d all.txt (425.6 KB)

Final lines before crash are:

dyld: lazy symbol binding failed: Symbol not found: _aligned_alloc
Referenced from: /Applications/darktable.app/Contents/MacOS/…/Resources/lib/darktable/libdarktable.dylib
Expected in: /usr/lib/libSystem.B.dylib

dyld: Symbol not found: _aligned_alloc
Referenced from: /Applications/darktable.app/Contents/MacOS/…/Resources/lib/darktable/libdarktable.dylib
Expected in: /usr/lib/libSystem.B.dylib

Magick: abort due to signal 6 (SIGABRT) “Abort”…
Abort trap: 6

Not sure if this is related, or a problem of note:

(process:3870): GLib-GObject-CRITICAL **: 20:26:25.903: g_object_set: assertion ‘G_IS_OBJECT (object)’ failed
0.736241 output profile XYZ identity built-in' color space XYZ ’ not supported for work or histogram profile

Any help is much appreciated…

For anyone wondering, this has been solved on github. It was a bug that affected old macs. New version is available at link: