[SOLVED] Failed to launch/run RPD 0.9.29 on MX Linux 19.3/19.4.1

Hi all,

Hope that you are well and safe.

I am looking for a way to make rpd works on my machine.
For the moment, I am running the install script successfully but when Ibam trying to run the software from my app menu (MX/whisker menu), I have a error:
“Failed to exécuté command “rapid-photo-downloader”, Failed to execute child process “rapid-photo-downloader” (No such file or directory)”

Do you have an Idea?

Thanks for any help :smiley::+1:

Can you try and launch it from a terminal and paste the output of the command here?

Hi paperdigits,
Thanks for your answer.
Here is the message I have when I run the command:

$ rapid-photo-downloader
bash: rapid-photo-downloader: command not found

what is the output of this command:

ls ~/.local/bin/

Hello Damon,
Here is the output:

$ ls ~/.local/bin/
pip  pip3  pip3.7  wheel

That indicates the program did not successfully install. Do you have a standard installation of MX Linux, or did you modify it in some way, such as installing programs from sources other than MX Linux?

No specific install :-s. Really very basic install (just some partitioning for system and data but nothing fancy). And no other software install from the source (no other than RPD), but I might have forgotten it, but don’t see any in my software list. Usually I stick to repos and flatpak/snap/appImage :frowning: .

Run the install.py script again and copy and paste here any relevant output, i.e. errors.

So I won’t have anything relevant to paste here :frowning:

  Stored in directory: /home/myusername/.cache/pip/wheels/9c/8b/fc/fb386fb0dd020f90408621c211ed3960439a5e47c52f4e5004
Successfully built rapid-photo-downloader
Installing collected packages: rapid-photo-downloader
Successfully installed rapid-photo-downloader-0.9.29

I would have liked to have error message but I don’t, and that’s why I am a bit “lost” in the way to solve this.
That might be very simple but I don’t understand where things failed…

Edit: I haven’t restart yet after the install but the output is (obviously) before this step so I don’t think that it matter here.

Edit2: I am rebuilding my environment in a VM to try it “from scratch” on a fresh install.

I observe the same issue on a fresh install, where the output of the “ls” command is a bit different and seems a little bit more “ok”

ls ~/.local/bin/
analyze-pv-structure pip pip3 pip3.7 rapid-photo-downloader showinfilemanager wheel

But still this “file or directory not found”/“Failed…”

You probably simply need to restart.

I’ll do asap but I will do that not being very confident about the result because I have already done a restard on my main machine and on the VM (I am cloning my VM to try on MX Linux 21 this time… but it is on Debian 11, so I think that it will be more problematic than anything else :stuck_out_tongue: ).

Edit: Same error after reboot

The technical reason to restart is because Debian does not include ~/.local/bin in the $PATH by default unless it detects it is being used at login. I do not know the historic reason for this, but they have done it that way for a long time.

If MX Linux does not do that for you for whatever reason, then you need to add ~/.local/bin to the $PATH yourself. You can do so in .profile or .bashrc depending on your setup.

1 Like


Just as simple as a PATH issue :face_exhaling:
It was a bit tricky and not sure I can reproduce it as I don’t really know when does the rapid-photo-downloader folder as been added in the ~/.local/bin directory… but after several “install.py” and 2 restart, it works :smiley:

Just as a note / FYI:
In the menu, I have had to edit the command for the full path: ~/.local/bin/rapid-photo-downloader %f

Thanks a lot for your help :+1: !!!

1 Like

Glad to see it’s now sorted out. It’s a bit odd however it didn’t work the first time. Is it possible the .bashrc and/or .profile in your home directory are from before 2016 or so? If so then they wouldn’t necessarily have the steps that Debian normally takes when it detects the presence of ~/.local/bin whenever the user logs in.

Hi Damon,
Sorry for not responding earlier !
About your question, I don’t think that it is from before 2016 (except if it is in MX Linux “2021”). My install is kind of fresh from the first quarter of 2021.