[Solved] Lighttable showing images that shouldn't be there

Hi,
I’m trying to get rid of these inconsistencies but so far haven’t succeeded.
The kid images don’t belong to that folder (as well as the monochrome one):


When I double click on the kid image on the first row, to enter darkroom, I get this:

When I switch back to lighttable, I get this:

What I did to get rid of this, without success:
1 - Move away library.db from ~/.config/darktable
2 - Move away ~/config/darktable
3 - Uninstall darktable

Am I missing something?

EDIT: The only thing I can think about that may have caused this is that sometimes I loose power on my computer while editing.

What do you have selected in the collect images module?

I haven’t touched on it. It shows like this:

image

This is certainly due to some old cached thumbnails. The simplest solution is to remove the cache folder .cache/darktable/mipmaps-…
This can happen if you play with databases : for example, recreate a new database, without removing the cache folder

Many thanks! It worked!

Lesson learned: whenever it’s necessary to recreate the library database (~/.config/darktable/library.db), the cache needs also to be recreated.

I wonder if one of the latest commits that changed the database could have missed cleaning the cache. I’m saying this because I don’t remember having manually reset the library database myself lately, though I’m not 100% sure about that.

EDIT: Oh, and welcome to this community. And thanks for helping develop this great software!