[Solved] No menu item for RPD after using install.py for latest version

I got a notification to upgrade when launching RPD.
I went through the process, and hit run; all working.
Closed the RPD. Then looked in the menu for it, and could not find it.

typed rapid-photo-downloader in the terminal, and it launched.

Then I read this: Fedora 30: RPD installed and working, but not sowing up in application menu
downloaded the install.py (which did not download, but appeared as text in the browser.
Copied the text and saved it; then ran it with python3 ~/Downloads/install.py

Still no menu item.

Then checked the path which includes ~/.local/bin
ran next:

python3 -m pip show rapid-photo-downloader
Name: rapid-photo-downloader
Version: 0.9.24
Summary: Downloads, renames and backs up photos and videos from cameras, phones, memory cards and other devices
Home-page: http://www.damonlynch.net/rapid
Author: Damon Lynch
Author-email: damonlynch@gmail.com
License: GPL 3+
Location: /home/maxg/.local/lib/python3.5/site-packages
Requires: arrow, colour, tornado, python-dateutil, pyxdg, pyzmq, PyQt5, babel, easygui, gphoto2, PyGObject, pymediainfo, psutil, sortedcontainers, rawkit


ls ~/.local/lib/python3.7/site-packages/
ls: cannot access '/home/maxg/.local/lib/python3.7/site-packages/': No such file or directory

then took this approach:

wget https://launchpad.net/rapid/pyqt/0.9.23a1/+download/install.py

and then:

python3 install.py --devel
Detected Linux distribution Linuxmint 18.3

pip will be upgraded from version 20.1.1 to version 20.2b1
These Python3 packages will be upgraded for your user (i.e. not system-wide): pip
The following command will be run:

/usr/bin/python3 -m pip install --user --upgrade pip --disable-pip-version-check

Requirement already up-to-date: pip in /home/maxg/.local/lib/python3.5/site-packages (20.1.1)
Downloading https://launchpad.net/rapid/pyqt/0.9.24/+download/rapid-photo-downloader-0.9.24.tar.gz (8.15 MB)
0% [##############################] 100% | ETA: 00:00:00
Total time elapsed: 00:00:12
Loading new installer script version 0.3.8
usage: Rapid Photo Downloader installer [-h] [--version] [-i] [--devel]
                                        [--PyQt5-version X.X.X]
Rapid Photo Downloader installer: error: argument --devel: not allowed with argument tarfile

Still no menu item…

but command line launch works.

How can I add the menu item for RPD?


Googling for adding a menu item…
and I found RPD in the menu editor.
Unticking and ticking it made it appear in the menu.


I’m glad you figured out how to fix it.

But next time please don’t copy and paste random commands into the terminal unless you know the purpose behind them.

Why would you download an old version of the installer from an alpha release, unless you had a very specific and well-defined reason for it?

Linux Mint 18.3 has Python 3.5, not Python 3.7, which is why there is no directory ~/.local/lib/python3.7/site-packages/