[Solved via workaround] G'mic - descreen - error


Hello David, little problem with the descreen filter in gmic for gimp.

I am on Xubuntu 20.04. I used to use the appimage for gimp 2.10.25 with gmic included. There I could use the descreen filter without problems.

Then I reinstalled the same Xubuntu on an new ssd. When I use the same appimage the descreen filter ends up with an error, see screenshot.

When I use the standard installed Gimp v. 2.10.18 with gimp-gmic from the repos, descreen works fine.

Any idea what’s going on? I use descreen on a regular base to eliminate the raster that is seen on scans from books.


Hello Paul.

Just tested here on my Ubuntu 20.04, with latest stable .deb package installed from the website (version 3.1.5), and I don’t get any error.
Could you tell me what G’MIC command the plug-in tries to run ? (using the “Paste Command to Clipboard” button located at the top-right of the filter parameter panel).
Also if you can provide an example of image that does not work.

If I can reproduce the bug here, I’ll probably be able to correct it (even though I’m not the author of this filter :slight_smile: ).


Salut David,

Problem solved - via a workaround.
I installed gmic_gimp_qt 3.1.5 and descreen works fine in the “official” Gimp that comes with Xubuntu 20.04 (v2.10.18), as it did with the earlier version gmic-gimp 2.4.5 (the one from the repos).

Only gmic 3.1.5 shows the button to copy the command to the clipboard, v2.4.5 and the gimp appimage with filters (gmic 2.9.2_pre#…) do not show that button.


The command in question is fx_pahlsson_descreen 0.

In the appimage (gimp 2.10.25) descreen produces another error msg:


I solved the whole problem by using gmic descreen from the commandline, I made a script to batch process several files, as this filter is a bit time-consuming.

Thanks for your time anyway.

Regards, Paul.

1 Like