Starnet in 1.2.0-beta2

Just installed beta2 and I had to reconfigure the path for Starnet. Not a big deal, but wasn’t sure if that was expected. Running the Windows version. Thanks for the great work everyone!

Yes this is “wanted”. Because the way we detect binary has changed.

1 Like

Tried to use Rich of DeepSpaceAstro’s script on both Win10 and Win11. Works on Win10 but not on Win11. One other user had the same issue on win11, but Rich is also on win11 and he did not have the issue. Rich asked us to issue the command to get the full path to the .exe file, and here’s my response: The star reduction script works on win10, but not on win11. I issued the get core.starnet_exe command on both win10 and win11 and got core.starnet_exe= C:\StarNet v2CLI_Win\starnet++.exe. I will post the issue on Siril’s forum. I’m using the latest Win11 updates - just installed one the day before yesterday, and i don’t have any anti-virus running, I just use the windows defender. Also, after I added the starnet++.exe under the Preferences>>Miscellaneous menu, I tried manually running Image Processing>>Star Processing>>Starnet Star Removal… and the Window showed the message “No valid StarNet executable found in the configured Starnet installation directory, Check your StarNet installation and Siril Configuration”

Hi Tom, don’t expect Siril to help you with my script, that’s on me. :wink:

Dev’s the underlying issue for Tom is he says Starnet is configured in the Preferences, yet it it still tells him that no valid exe was found. He also says he is using the the CLI of Starnet.


the test we run to check if the file is valid is quite simple. On Windows, we just basically check that the file exists AND that it ends with a executable common extension (.exe being one of them).
The only thing that bothers me is:
get core.starnet_exe returns in your case:
core.starnet_exe= C:\StarNet v2CLI_Win\starnet++.exe
with a space in the path while the archive at does not have a space in the zip filename.
I’ve also tried on my laptop to use the same path as you (copying starnet++.exe and weights in a folder C:\StarNet v2CLI_Win\ and pointing to that exe) and it does work…
So I must say I’m a little short of ideas, except some specifics of w11, I’m on w10. Anyone with w11 running into the same problem?


I have Win11 and it works. I tried renaming my folder to include a space, and it still works after that as well.

@Rich_Stevenson, Thanks for testing!
@Tom_Burnett, what do you get if you type:
"C:\StarNet v2CLI_Win\starnet++.exe" "C:\StarNet v2CLI_Win\mono_test5.tif" in a cmd window?

@cissou8 I may have just figured out his issue.
@Tom_Burnett You have all of the files that were included in the .zip from Starnet in your folder, correct? If you only copied over the starnet++.exe then that’s your issue.

Not sure that’s it… the test that writes that message does not try to launch starnet but just checks whether or not starnet++.exe file exists. Meaning if the weights, for instance, have not been copied over, it won’t be detected at this stage but later on.

Hmmm ok. I deleted all of the files from my dir except the .exe and got the same message he did, that’s why I was asking.

Indeed, you’re right!!!
The tests have changed recently (between beta1 and beta2) and there’s more to it than just the initial check I was mentionning before. It tries to launch starnet to get the version number. And anything missing in the folder will lead to failure of the test.
Good catch! Thanks!

1 Like

I copied all the files in the .zip file to the root of the C drive, and I also tried putting the files in the Siril home directory, after that failed. Neither method worked on win11, but it did work on my win10 laptop. I will check again to see if there was a space in the root drive path, but that may have just been a typo in my message. I wonder if it might be a permissions issue? One other user, Jose, had the same issue on win11, but another win11 user, Rich, had no problem on his win11. It’s not a big issue as I can run on win10.

If you don’t mind continuing testing a bit, if you type the following in a cmd window:
"C:\Astro\StarNetv2CLI_Win\starnet++.exe" --version
(just correct the path to the exe to match the location on your PC), what do you get?

I tried the command, and got this error message:

Command execution failed: unknown command name.

I tried it both with and without the ", but I dont have any spaces in the directory, as i just paced it at the root of the C: drive.

Here’s my actual command, copied from the window:

C:\StarNetV2CLI_Win\starnet++.exe --version

Here’s the text from the command window:

16:28:30: Unknown command: ‘C:\StarNetV2CLI_Win\starnet++.exe’ or not implemented yet
16:28:30: Command execution failed: unknown command name.
16:28:48: Unknown command: ‘C:\StarNetV2CLI_Win\starnet++.exe’ or not implemented yet
16:28:48: Command execution failed: unknown command name.

ok, what I meant was from a cmd window outside of Siril. The terminal window you get when you type cmd in Windows bar…sorry if the instructions were not clear

just noticed the upper case V in the file name so I tried again with lower case v, same result. Usually windows is not case sensitive like Unix and Linux.

just covering all the bases.

It’s almost like Siril doesn’t see the file in the windows file system, which might be a permissions issue?

@Tom_Burnett Did you run it from the windows command line? Right-click the Start menu button, select Run. In that box type cmd, and click Ok. In that command line window type C:\StarNetV2CLI_Win\starnet++.exe --version and hit Enter. You’ll probably see an error, but that’s fine. What you’re looking for is a line that says StarNet++ v2.0.

@cissou8 I don’t think --version is a valid switch, but nonetheless the version number is displayed after the error.

Yes Windows is case insensitive, but I think you may have missed my last message. You should do the testing not within Siril but in a cmd window (so that we can take Siril out of the equation)

yep, it is valid for “newer” versions of starnet (the experimental ones for MacOS). But as long as we get a backtrace where we can read StarNet++ v2.0, we know which version it is :wink:
I’m just trying to reproduce exactly what’s in Siril code but outside of Siril

popped up a window - sorry don’t remember how to copy on pc

title of window is:

startnet++.exe - Application Error

Inside the window:

The application was unable to start correctly (0xc0000142).
Click OK to close the window.