Starnet in 1.2.0-beta2

Will do Vincent, just how do I do that?

Right, if I drag and drop the rgb_test5.tif file onto the application icon (starnet++.exe) i get a bunch of errors about .dll not being found: The code execution cannot proceed because MSVCP140.dll was not found. Reinstalling the program may fix the problem. and then same messages for the following dll’s: VCRUNTIME140_1.DLL & VCRUNTIME140.DLL

If you cannot make StarNet works, for sure Siril won’t.
You need to fix that before.

You might try installing the latest Visual C++ Redistributable from Microsoft.

Grab the latest under the Visual Studio 2015, 2017, 2019, and 2022 section from the link below.

Amazing! Thank you guys! Done and it works!!

1 Like


I am getting this same error in Windows 11. “No valid StarNet executable found in the configured Starnet installation directory, Check your StarNet installation and Siril Configuration”

Works fine on my Windows 10 machine, not on my Windows 11 lap top. I have read the forums, and suggestions. Still have not seen a clear explanation of why this happens to some users of Win 11 and not others.

Have you aware of how to fix this problem on Windows 11 Pro?

|Edition|Windows 11 Pro

|Installed on|‎3/‎8/‎2023|
|OS build|22621.1848|
|Experience|Windows Feature Experience Pack 1000.22642.1000.0|

Thanks for your help and your great Siril tutorials.
Best regards.
Michael - N9XY
N9XY on Astrobin

Thanks!!! this fixed my problem with Windows 11!!

1 Like

Problem resolved… Thanks

1 Like

Please excuse the late reply. Rich from Deep Space Astro, thanks Rich, was able to point me to my Intel Pentium G4560T; it does not feature AVX . That explained what was/is going on. Thank you all for your help and sorry to have bothered you with “my issue”, not a a Siril or Startnet++ issue. Please continue with your great work.


Still having a problem running starnet on Siri 1.2. Downloaded unzipped. No firewall . No windows defender stopping the file running. Won’t find starnet++.
Processor is a pentium N6000
Downloaded latest visual C+C and installed. Still won’t execute.
Tried to run application from folder
Message application was unable to start correctly (0xc0000142)
Any help would be appreciated

For all people wondering why starnet doesn’t launch, please run it outside siril first. It’s not siril’s fault if it’s not supported by your computer or badly installed for some reason.
Garry, your processor does not support the vectorization instructions required by starnet, I don’t think there is a way to bypass that. The error message will be obtained by executing starnet alone.

Thanks Vincent
Good to know a straight answer
Will save me a lot of time
Shame as computer brand new acer
Purchased for the software