Strange behavior of drawn mask

I awas just doing a PlayRaw when I encountered a problem with drawn masks in darktable 3.0
My expectation is that the mask delivers 100% blending inside and 0% outside.
But what I get is this:

When inverting the mask I get this:

I found out that I get the expected behavior when I remove my database, the folder ~user/.config/darktable
But I would like to stick to my database and only correct the behavior of the mask.
Does anybody has an idea how to do that?

Marco

I think this is to do with the mask shape retaining some default opacity from a previous shape(?). I have this all the time with darktable 3. Hold the control key down and scroll while your mouse is over the shape. This should alter the opacity.

I still haven’t worked out how to get it to retain that opacity for the next shape though.

Edit: There was an issue raised (https://github.com/darktable-org/darktable/issues/3685) which randomly sorted itself out for the person who raised it. It seems this has ‘self-healed’ for me as well, and my drawn masks now work fine.

There is a parameter in the darktablerc file “plugins/darkroom/masks/opacity”. Perhaps try setting this to 1?

2 Likes

Hi Chris,

your tip with the control key + scrolling the mouse wheel works :grinning:
So I can manage it for now, but unfortunately there is still something screwed up.
The next mask starts again with less than 100% opacity…
Well, maybe I should wait for the "self-healing :wink:

Thanks,
Marco

Have you tried setting the parameter I suggested in $HOME/.config/darktable/darktablrc? Make sure you exit darktable first.

I just tried it. That does the trick!
Now my masks start with 100% opacity :grinning:

Thanks for your help!

1 Like

I have a perhaps (?) similar problem.
In most of the tools I tried my drawn AND drawn&parametric masks simply don’t work.
(Parametric masks are OK!)
I try extreme values, different color spaces, different blend modes…
The selected area does not change.
The rest of the image also remains the same as if the module has not been activated.
Just an example (the problem is not limited to this module):


Note the exposure slider above.
If I am alone in this, what do you think might have gone wrong?

1 Like

You are not alone, I have the same issue also.
Check the $HOME/.config/darktable/darktablrc entry “plugins/darkroom/masks/opacity”
When I encounter strange behaviour of the masks, that opacity value is below 1.
Unfortunately I don’t have a clue when and why that value changes…
Change the value to one and the masks work as usual, till…

1 Like

Unfortunately, that was the first thing I did after reading this thread. It did not work.

By the way, my retouch module also behaves erratically…
I suspect all these may turn out to be something I did unknowingly… I have no idea.
I am thinking of re-installing darktable.

I did reinstall. The same version (3.0.0-1) from a different repository.
No change!
See this: Mask-problem-2

You’ve tried ctrl-scroll to change it as well? My recollection is that the opacity slider in your screenshot is the opacity applied to the blend. The shape’s opacity is controlled with ctrl-scroll.

And if you’re changing darktablerc file, make sure you’re out of darktable when you do it.

What happens when you move or delete the folder: $HOME/.config/darktable ?

OH!
After clicking ctrl-scroll on the mask it responded!!!
Is this new to ver. 3.0?
As far as I remember, it was not like this.

Chris’s reply helped already.
I did not mess with the config files except for the mask opacity setting.
Still, I note your suggestion for future problems (due mostly to my ignorance, by the way).

Bulent, I had exactly the same issue and same solution as you, fixed just now by reading this thread.

Not sure how this setting gets like that. Would like to know it isn’t going to happen too often!

2 Likes

I had this happen to me on one of the 3.0 RCs and just again today. I was in the middle of editing and palced a drawn mask with no problems. A few minutes later, without switching files or exiting to light table, the next drawn mask barely showed. Luckily I knew to use ctrl + mouse wheel but I have no idea how the setting the darktablerc got changed.