Trouble integrating AppImage with system in Pop!_OS

Hi, I’m a photographer from Romania, and I’m a fresh Linux convert (about 3 weeks since using it fulltime) after having used Windows for the last 20 years.

I’m using Pop OS and it’s app store only has 5.5. I got the 5.6 .appimage off of the official site, but I can’t seem to integrate it into the system to be searchable. Even more so, while runing the appimage itself works, sometimes I will find it disappeared completely overnight.

Can you help me find a .deb of 5.6, or maybe teach me to integrate the .appimage?

Hi! And welcome to this forum!

I am the maintainer of the AppImage package, so I will try to help on this…

I am not familiar with PopOS and I never tried the AppImage on this system, so I will first need to run some tests.

First question: what do you mean by “disappeared completely overnight”?

Hi and thanks for offering your help.

If I remember correctly, Pop OS will ask users if they want to integrate an appimage on first run. I chose yes, the app was searchable and it appeared in the software manager app. Then, upon my next login, both the .appimage file and the software center entry were completely gone.

I had to redownload the .appimage, only to find it disappears again on next login.

@zerosapte where have you downloaded the AppImage to? Show a ls -la ~/path/to/the/appimage

Downloads folder.

“Downloads folder.” is not the output of “ls -la ~/path/to/the/appimage”.

Into which folder do you download the appimage? I am surprised that it gets deleted…

The integration is handled by the appimage itself, not by the system. Could you run the appimage from the terminal, and post the full terminal output? Like this:

./RawTherapee*.Appimage >& log.txt

Then provide us the log.txt file, maybe it will give some hints…

Pasting that command into the terminal does nothing. I don’t know how to proceed.

Please help me help you help me.

Ok, sorry, let’s take one step back…

  • open a terminal window
  • go into the folder where you downloaded the AppImage. For example
cd ~/Downloads
  • make sure the AppImage is executable:
chmod u+x RawTherapee*.AppImage
  • run the command I suggested before:
./RawTherapee*.Appimage >& log.txt

I hope the steps are clear…

Here is what’s in the log.txt file:

bash: ./RawTherapee*.Appimage: No such file or directory

I even tried replacing ./RawTherapee*.Appimage with the actual filename, as in RawTherapee-releases-5.6-20190420.Appimage, but the result was the same.

Sorry, I had a typo in my message, you should run the following

./RawTherapee*.AppImage >& log.txt

The last “i” should be uppercase…

OK, that worked. log.txt (10.1 KB)

edit: I find it strange that it doesn’t ask me if I want to integrate it anymore…

@Carmelo_DrRaw Have you managed to take a look at the log file I sent?

Later edit: I just grabbed the latest 5.6 nightly build and the appimage appears to integrate itself just nicely.

Nothing has changed from my side… let’s keep an eye on this and let me know if you get again some misbehaviour.
So far I could not find anything strange in your log…