Upgraded Darktable 4.2.1 win64, now DT just quits

Yes, it uses it to convert any format it doesn’t understand natively. Either imagemagick or graphicsmagick, either works

Okay. magick should never crash with an access violation, of course. Is there a log entry that says what magick command was attempted?

What version of ImageMagick was used? “magick -version” will say.

If the problem is reproducible outside darktable, ie at the command line, then I expect that is fixable by the ImageMagick people if it is reported at Issues · ImageMagick/ImageMagick · GitHub

Possible workarounds: upgrade to a current version of ImageMagick, or remove ImageMagick and let GraphicsMagick do the work.

That’s because I used the application for work, my clients expect results rather quickly. You guys seem to be judgemental and make assumptions about my reactions, not upcommon in forums I’ve noticed, unfortunately.

It’s fine though. I’ll wait for a future software release and test it. No hard feelings I hope, and have a great day!

1 Like

You say you’re a software developer, you know that’s not how problems get fixed.

if you’re a developer as you wrote before you’ll obviously know, that issues usually aren’t solved by magic. So you might just wait and pray, but since no developer ist on windows i doubt, just a diagnosis of symptoms will help.
Bite the bullet, try to play with different opencl settings, make use of the debug output options if started from command line and provide valuable hints to help the developers to help…

Of course this needs time, but why should a developer spend his spare time to solve an issue that’s not worth that you spend time to help to find a reason…

I never asked for any issues to be solved, and I certainly don’t expect them to be solved magically. I only expressed the fact that the issue came to be after the upgrade to 4.2.0. This should give enough information for the developers to hopefully solve the issue. This isn’t uncommon. My clients expect a specific turnaround time so I decided to use a different software (which I didn’t mention by name), until the issue is fixed. I was very clear in my post, but apparently most people chose to read more into it, that’s their prerogative and yours. Sorry you see things this way.

Thank you, I will try that.

DT 4.2.1 just quits, just like the title in this thread. It appears to start up, but then nothing, also no DT in Task Manager.

So you did this…

down load the 4.21 from the website.

Install in directory

Say DT421

Create short cut that runs. C:\ProgramFiles\DT421\bin\darktable.exe --configdir “path” where path is a new directory maybe one on the desktop or other easy to find location for now…

You did this and it fails??

Edit: If this fails one other question…do you run an antivirus or did you install one… at work TrendMicro flags DT and it wont’ run …you see a flash on the screen and then nothing…
any chance of this??

The command line version seems to be working, I will update the shortcut to include the --configdir parameter. I will test 4.2.1 performance and reply with feedback. Thanks Todd!

Definitely not. Hence wanting more information.

Sadly this is true and very common.

I switch to win11 this morning and windows did all the 50 updates it likes to do. After a restart, I started running darktable using the last build I had in my system (darktable-4.3.0+467~gaf54ffe9a). This was a build I did 04FEB and used it for a little bit.

darktable was slow. Mainly in the closing of darktable. It just stayed running in the background for a few minutes before it finished.

I decided to update my build environment and do build on the current master darktable-4.3.0+1329~g7abc527b6e. Installed it and used the same configuration folder as before. darktable is now running like normal.

My next steps (likely tomorrow) is to build 4.2.1 on my build environment and compare with 4.2.1 from the website (older build environment). I’m working on the hypothesis that something in windows changed in the 50 weekly updates they do.

1 Like


I am running Windows 10 and Windows Security, no other anti-virus software.

So here’s what I experienced: DT 4.2.1 did start (more on that later). I made a couple of image edits then suddenly it existed/crashed. I checked Task Manager and confirmed it was gone.

The other issue I experienced is that DT doesn’t run from the shortcut, even with the --configdir switch, it started then exited immediately. I pasted the same exact command that is in the shortcut at the command line, and it started just fine, but as I mentioned it crashed while editing an image.

I rebooted my computer and started DT 4.2.1 from the shortcut, it did start this time and it seems more stable, however there is a hanging command line window in the background, not sure if this is a debug console or a Windows command line. CTRL-C doesn’t do anything. That “console” window closes once I exist DT. This window did not present itself in DT 4.2.0.

Performance after the reboot seems to be great, as I expect it. DT hasn’t crashed since. I have a feeling that another software may have some sort of memory leak which is causing DT to slow to a crawl, or crash. I will investigate further.

Thanks for your help and suggestions!


There is a bunch of chatter about the latest win 11 update slowing SSD drives and some other issues … could be some of that going on??