Usb drive not accessible on startup

(Edgardo Hoszowski) #1


Sorry if this is not photography related and probably a basic question, but I just moved to Linux after a year or so of using a VM and I’m facing some issues as a new user.

I use an external HHD to store my pictures. When I plug it in, xubuntu detect it and it works fine, but if I boot with the drive already plugged and enter darktable I can’t access the pictures. If I go to the file manager and select the HHD, then go back to darktable, everything is fine again.

I’m not even sure what the problem is, but seems that I’m doing something wrong…


The file manager knows it’s there but it’s not mounted and ready to use until you click on it. darktable doesn’t know it’s there and isn’t able to mount it, so you have to mount it using the file manager first.

(Edgardo Hoszowski) #3

Is there any way to make it available on startup without having to manually mounting it?

(Pat David) #4

There sure is, but I’m not near a machine to detail the steps. If nobody else hops in before tomorrow I’ll post what I added to my /etc/fstab.

(Edgardo Hoszowski) #5

I kind of fixed, knowing the problem make the search easy, I’ve missed the auto-mount before.
Thanks all for the help!

(Pat David) #6


I have my disks mounted in /etc/fstab using their UUID:

UUID=45E0768F1702DB53   /media/Media   ntfs-3g auto,nofail,user,rw 0  0

That’s one of my drives entry in /etc/fstab. This keeps the same drive mounted at the same mountpoint for me.

There may be easier ways to have this happen in xubuntu, but it’s the way I’m familiar with personally, so I’ll defer to what someone else may suggest. :slight_smile:

(Edgardo Hoszowski) #7

My first attempt was with the Disk Utility, but I have a windows partition (for data) that does not show in the list and I couldn’t find why, so I went for the fstab:

/dev/disk/by-id/usb-WD_My_Passport_0748_575834314139323832353634-0:0-part1 /mnt/usb-WD_My_Passport_0748_575834314139323832353634-0:0-part1 auto nosuid,nodev,nofail,x-gvfs-show 0 0
UUID=A606795906792B85 /mnt/sda6 ntfs defaults 0 2

I just follow a tutorial and didn’t explore each parameter, so maybe there are better options, but it’s working and I have other issues to work on, so for now this is ok.