Windows CLI filter problem.

I’m getting this error using Windows GMIC CLI Version 2.9.2, with the filter ‘Crazy Texture’ (“fx_crazy_texture”), the GUI version is at Testing>Joan Rake>Rendering>Crazy Texture.

   C:\Users\1369s\CML>gmic H_04.png fx_crazy_texture 0,37.96,168,7.85,4.0,56,26,0,4.59,1,0,0,-75.4,4.05,0,58.12,1,-86.6,1,0.712  o test_0000.png

[gmic]-0./ Start G’MIC interpreter.
[gmic]-0./ Input file ‘H_04.png’ at position 0 (1 image 1280x720x1x3).
[gmic] *** Error in ./fx_crazy_texture/_crazy_texture/jr_deform/*repeat/*local/*if/ *** Command ‘input’: File ‘0’, format does not take any input options (options ‘0,1,4’ specified).

Any idea how to fix this? Thanks.

Confirmed, working on a fix.

1 Like

Actually, cannot fix this easily. The code of this filter seems to pass strange values of arguments (here $3=0) to the command jr_deform, which is probably not intended.

I’ve done a small fix to avoid the code trying to create 0x0 images, but there is probably something more to do : https://github.com/dtschump/gmic-community/commit/a1ec2c6ec8369f738645a6af12a22cb26d8ea51a

At least, the filter succeeds with this fix. Not sure if it is enough, @Joan_Rake should have a look more closely.

The fix should be available in one hour or so, after a $ gmic update.

1 Like

Thanks very much for looking into this, I updated and yes, it seems to be working fine, much appreciated David! :smiley: