Windows crashed during compiling process


#1

Hi fellows,

I encountered a weird issue. Basically, Windows 7 64-bit crashes during the compiling process of RT. This issue was firstly observed after I installed Capture One. By uninstalling Capture One and restoring the system, it was fixed for a period of time. A couple of days ago, Windows did a update, this issue came back. Windows crashes at random places in the compiling process of RT.

Did anybody observe this issue too? Any comments or suggestions would be appreciated.

Chong


(Morgan Hardwood) #2

Such is Windows.

You need to provide meaningful information. How does it crash? Do you get a BSOD? What is the error code in it? Are you monitoring your system resources during compilation? Are you monitoring your system temperatures? etc.


#3

Yes, I got a BSOD and I tried to use WinDBG to figure out what caused it. However, WinDBG failed to find the reason because it couldn’t find the symbols, even though I put in the link to the Microsoft symbol server.

I also monitored the resources, nothing abnormal was observed before the crash. The temperature shouldn’t be the problem either (I’m in the SF bay area, it’s pretty cool here recently)

It feels like to me the crash is related to multi threading compiling, since the it didn’t crash when the compiling is done with single thread.


(Alberto) #4

are you compiling with an unbounded number of threads, or are you putting an upper limit to the number of parallel jobs? if the former, that could explain it


(Ingo Weyrich) #5

Most likely overheating of CPU. I get the same on my 8-core when I compile RT from scratch on all cores -j8.
When I compile using only 2 cores -j2 it works fine. After cleaning the heat sink compiling on all cores should work again.


(Morgan Hardwood) #6

BSOD typically tell you what went wrong and where. What is the error code in it?

Are you saying that you did not monitor the temperature, but just assume it’s not a problem because you live in the SFBA?


#7

First of all, I’d like to thank all you guys for the kind replies.

The CPU temperature before crash was 82 degree centigrade. I don’t know if this is too high. However, when I compiled RT on the same machine with Linux, it didn’t have any issue, even when 8 threads. For this reason, I assume the CPU temperature is not the problem.

I also tried to find what the error code was. Here is the information I collected using WinDBG (I’m not sure if this is what I should present.)

DUMP_TYPE:  2

BUGCHECK_P1: ffffffffc0000005

BUGCHECK_P2: fffff88013ac6b30

BUGCHECK_P3: fffff88010b230d8

BUGCHECK_P4: fffff88010b22930

EXCEPTION_CODE: (NTSTATUS) 0x5902893d - <Unable to get error code text>

FAULTING_IP: 
mfeavfk47+7b30
fffff880`13ac6b30 ff5058          call    qword ptr [rax+58h]

EXCEPTION_RECORD:  fffff88010b230d8 -- (.exr 0xfffff88010b230d8)
ExceptionAddress: fffff88013ac6b30 (mfeavfk47+0x0000000000007b30)
   ExceptionCode: c0000005 (Access violation)
  ExceptionFlags: 00000000
NumberParameters: 2
   Parameter[0]: 0000000000000000
   Parameter[1]: 0000022800000058
Attempt to read from address 0000022800000058

CONTEXT:  fffff88010b22930 -- (.cxr 0xfffff88010b22930)
rax=0000022800000000 rbx=fffffa8027e3a340 rcx=fffffa801a820010
rdx=fffff88013b02520 rsi=00000000c0000017 rdi=fffff88013b0d970
rip=fffff88013ac6b30 rsp=fffff88010b23310 rbp=0000000000000000
 r8=fffff88010b23370  r9=0000000000000000 r10=fffff88013b03604
r11=0000000000000000 r12=0000000000000000 r13=ffffffff80000ed0
r14=fffffa8026ffd9f0 r15=000000000000001c
iopl=0         nv up ei pl zr na po nc
cs=0010  ss=0018  ds=002b  es=002b  fs=0053  gs=002b             efl=00010246
mfeavfk47+0x7b30:
fffff880`13ac6b30 ff5058          call    qword ptr [rax+58h] ds:002b:00000228`00000058=????????????????
Resetting default scope

#8

Dear fellows,

I think I found the cause of the crash. It’s the McAfee total protection that crashed Windows during the compiling of RT. After the removal of McAfee, RT compiles smoothly with 8 threads.

chong