(Windows) The mouse doesn't seem to know where it is

Hi

I am giving Raw Therapy a try (I use Windows 10, and I have RT5.3)

The problem that I have is that the UI just doesn’t work properly. I can’t find anything about this online, so it seems like it might only be me, I really don’t know.

The problem is that clicking anywhere on either of the side panels don’t seem to work, the click goes through the panel, this means I can double click on something (Like Exposure on the left) and the image will zoom in. If I drag the mouse on any slider, the image drags around.

Like I said, it is as though the click is not getting handled by the panel, and dropping through to the image.

I do not know what information could be helpful to anybody, but I am willing to try help (where I am able) with anyone who might know what is going on or wanting to find out.

Any help is appreciated.
Thank you
Jonathan

Hi @JonathanPeel

Could you try both of the 64-bit Windows development builds and report whether the problem still exists?

Thank you so much for such a quick reply.

A little feedback

@gaaned92 build.
This seems to be exactly the same as the one I had downloaded to install RT. RawTherapee_5.3_WinVista_64. It installed but has the same problems.

The first screen has a file tree on the left, and thumbnails in the middle.
I can use my mouse wheel and scroll the tree, but I cannot open a directory. Clicking does not do anything.

If I click on the top left thumbnail, the second middle thumbnail is selected. After that, clicking any thumbnail will select/deselect the second-row image on the right. Clicking random thumbnails, eventually one opens.

I can drag the image around and zoom in and out.

I can use the mouse wheel and scroll up and down the toolbox on the right,

Clicking seems to click about 6cm above where I am clicking. Hovering my mouse over Tint shows the tool tip for CIECAM02. Clicking on Tint checks/unchecks CIECAM02.

Clicking on the Lightness (J) slider opens the dropdown for Tone Curve 1 (a few cm below)

@Carmelo_DrRaw
This is more of a standalone build. No Installer.
This is very similar, I can scroll up and down the directory tree, but not click on anything.
Getting an image open, it looks a little different, but I think the build is on a much later branch.

As far as using the controls on the right, it is the same thing. The control in the middle (relative to my visible screen) seems to be in line, then as my mouse goes up or down, the point the mouse is “pointing” to moves up and down, but “slower”, so if I move up by the height of two controls my click hits one control higher, and if I move my mouse six controls higher, my mouse moves two controls higher (I don’t know how explanatory my description is)

There is a right-hand tool box, with thumbnail and history. Clicking and dragging anywhere in the right column drags the image around.

On https://keybase.pub/gaaned92/RTW64NightlyBuilds/

, instead of the “stable” Rawtherapee_5.3_Winvista_64 build, you should download and test the build

RawTherapee_dev_5.3-433-g3fe9cae2_WinVista_64.zip

“dev” meaning that it is a “development” build from the dev branch.
Thus you will get the last modifications made by the developpers.

There were some Windows 10-related fixes that went into RT since 5.3 was released. Though I haven’t heard anyone describe the bugs you describe, these fixes may be related. As I recall, the fixes required updating the toolchain used to compile RT. I assumed those development builds make use of the fixes, though I could be wrong - I don’t use Windows myself. @gaaned92 @Hombre @TooWaBoo do you recall what the situation was and where we stand?

@Morgan_Hardwood

I remember that on Windows, GTK3 used a specific window that was not reacting like a genuine W64 window. With last builds, it is corrected and RT is displayed in a normal window.

I don’t remember any problem with mouse pointing and clicking.

Here on my W10 PC the situation is normal with my builds. I am going to test with @Carmelo_DrRaw automatic builds.

edit: no problem with mouse with automatic build

1 Like

@JonathanPeel
I’m on WIN 10 x64 and I never had this behavior.
Can you give us more information about your hardware, please?

@gaaned92 I have tried the dev installation, but it is still the same.
It makes sense that it is a GTK problem, it feels like a UI Toolkit issue. Like I said, the mouse position seems to be detected incorrectly.

@TooWaBoo
My computer is an Alienware 15 R2, from properties:

  • Manufacturer: Dell
  • Processor: Intel i7-6700HQ @ 2.60GHz
  • RAML 16GB

Okay, so I was going through this, and saw “Pen and Touch”, and decided to try a different mouse, and you know, it works, so the problem is my Wacom mouse.

My guess might be that the mouse position is being taken relative to the pad (like in Pen mode).

I think this is still wrong, but it is an explanation, and it gives a workaround.

And at least it points out the difference.

2 Likes